Fixes a fatal constness error with g++ 4.8.2.
--- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100
+++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100
@@ -182,7 +182,7 @@
// Use optimizations in memchr when possible.
if (needle_len == 1)
- return memchr(haystack, *needle, haystack_len);
+ return (void *) memchr(haystack, *needle, haystack_len);
// Minimizing the worst-case complexity:
// Let n = haystack_len, m = needle_len.
ain'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-07-20 | Revert "gnu: libunistring: Fix make check for the Hurd."...This reverts commit 12e6a5923812abf180f03bea9e07dd99244a3fcd, which used
XFAIL_TESTS to have 'make check' pass with failing tests "test-perror2"
"test-strerror_r" that now pass with glibc-2.37 and libc-for-target in
commencement.
| Janneke Nieuwenhuizen |
2023-05-31 | gnu: libunistring: Fix make check for the Hurd....* gnu/packages/libunistring.scm (libunistring)[arguments]: Set XFAIL_TESTS
with test-perror2, and test-strerror_r when building to the Hurd.
| Janneke Nieuwenhuizen |
2022-05-28 | gnu: libunistring: Rewrite using gexps....* gnu/packages/libunistring.scm (libunistring)[arguments]: Rewrite using
gexps. Remove trailing #t.
| Efraim Flashner |
2022-05-28 | gnu: libunistring: Update to 1.0....* gnu/packages/libunistring.scm (libunistring): Update to 1.0.
[license]: Update in accordance with upstream.
| Efraim Flashner |