Fixes a fatal constness error with g++ 4.8.2. --- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100 +++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100 @@ -182,7 +182,7 @@ // Use optimizations in memchr when possible. if (needle_len == 1) - return memchr(haystack, *needle, haystack_len); + return (void *) memchr(haystack, *needle, haystack_len); // Minimizing the worst-case complexity: // Let n = haystack_len, m = needle_len. >index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/aidc.scm
AgeCommit message (Expand)Author
2022-07-17gnu: libdmtx: Omit static library.Tobias Geerinckx-Rice
2022-07-17gnu: libdmtx: Update to 0.7.7.Tobias Geerinckx-Rice
2021-12-18gnu: barcode: Fix build with GCC 10.Leo Famulari
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-11-11gnu: zxing-cpp: Update to 1.2.0-0.00783db.Maxim Cournoyer
2021-11-11Revert gstreamer update to 1.19.2.Maxim Cournoyer
2021-11-11gnu: zxing-cpp: Update to 1.2.0.Maxim Cournoyer
2021-06-19Merge branch 'master' into core-updatesMarius Bakke
2021-06-14gnu: Rename qtbase to qtbase-5.Maxim Cournoyer
2021-04-19gnu: zbar: Update to 0.23.90.Raghav Gururajan
2021-03-29gnu: qrencode: Enable tests.Efraim Flashner
2021-03-29gnu: qrencode: Update to 4.1.1.Efraim Flashner
2020-11-19gnu: Don't append '.git' to GitHub uris.Efraim Flashner
2020-08-18gnu: Add zxing-cpp.Raghav Gururajan
2020-07-12gnu: Remove ".git" from "https://github/…/….git".Ludovic Courtès
2020-04-18gnu: qrcodegen-cpp: Update to 1.6.0.Efraim Flashner
2020-02-13gnu: Add qrcodegen-cpp.Leo Famulari
2019-10-20gnu: Remove more GCC < 7 workarounds.Marius Bakke