Fixes a fatal constness error with g++ 4.8.2. --- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100 +++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100 @@ -182,7 +182,7 @@ // Use optimizations in memchr when possible. if (needle_len == 1) - return memchr(haystack, *needle, haystack_len); + return (void *) memchr(haystack, *needle, haystack_len); // Minimizing the worst-case complexity: // Let n = haystack_len, m = needle_len. ndex : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
AgeCommit message (Expand)Author
2023-11-15gnu: openmpi: Update to 4.1.6.Ludovic Courtès
2023-11-15gnu: hwloc: Update to 2.9.3.Ludovic Courtès
2023-09-14gnu: openmpi: Enable PMIx.Lars Bilke
2023-07-11gnu: hwloc: Update to 2.9.2.Philippe SWARTVAGHER
2023-05-31gnu: Add updater input properties for R and Python packages.Ludovic Courtès
2023-05-28gnu: python-mpi4py: Update home-page.Liliana Marie Prikler
2023-05-24gnu: python-mpi4py: Update to 3.1.4.Ludovic Courtès
2023-04-24gnu: openmpi: Update to 4.1.5.Ludovic Courtès
2023-04-07gnu: Purge pre-1.3.0 deprecated packages.Bruno Victal
2023-04-07gnu: hwloc: Update to 2.9.1.Philippe SWARTVAGHER
2023-02-27gnu: hwloc: Skip failing test on non-x86 systems.Simon South
2023-02-27gnu: hwloc: Remove obsolete comments.Simon South
2023-02-27gnu: Fix openmpi related packages.Christopher Baines
2023-02-23gnu: openmpi: Use gexps.Ludovic Courtès
2023-01-27gnu: hwloc: Update to 2.9.0.Ludovic Courtès
2022-11-11gnu: java-openmpi: Remove unused module import.Marius Bakke
2022-10-31gnu: Fix various lint issues in synopsis and descriptions.Vagrant Cascadian