--- a/adb/Android.mk 2018-04-25 23:23:29.527198350 +0200 +++ b/adb/Android.mk 2018-04-25 23:24:25.558632573 +0200 @@ -226,7 +226,7 @@ LOCAL_SRC_FILES := test_track_devices.cpp LOCAL_SANITIZE := $(adb_host_sanitize) LOCAL_SHARED_LIBRARIES := libbase -LOCAL_STATIC_LIBRARIES := libadb libcrypto_static libcutils +LOCAL_STATIC_LIBRARIES := libadb libbase libcrypto_static libcutils LOCAL_LDLIBS += -lrt -ldl -lpthread include $(BUILD_HOST_EXECUTABLE) endif @@ -278,6 +278,7 @@ LOCAL_SANITIZE := $(adb_host_sanitize) LOCAL_STATIC_LIBRARIES := \ libadb \ + libcutils \ libbase \ libcrypto_static \ libdiagnose_usb \ --- a/adb/sysdeps_test.cpp 2018-05-09 23:58:46.583163684 +0200 +++ b/adb/sysdeps_test.cpp 2018-05-09 23:56:41.356544648 +0200 @@ -17,6 +17,8 @@ #include #include #include +#include +#include #include "adb_io.h" #include "sysdeps.h" itch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2020-01-16lzlib: Define 'dictionary-size+match-length-limit'.Ludovic Courtès
* guix/lzlib.scm (%compression-levels): Splice the rest of each element. (dictionary-size+match-length-limit): New procedure. (make-lzip-output-port, make-lzip-input-port/compressed): Use it. * tests/lzlib.scm ("Bytevector of size relative to Lzip internal buffers (2 * dictionary)"): Use 'dictionary-size+match-length-limit' instead of 'assoc-ref'.
2019-12-01tests: lzlib: Do not fail if lzlib in not available.Mathieu Othacehe
* tests/lzlib.scm: Use test-assert* for all test cases, so that there are no failures if lzlib is unavailable.
2019-05-27lzlib: Add 'make-lzip-input-port/compressed'.Ludovic Courtès
* guix/lzlib.scm (lzwrite!, make-lzip-input-port/compressed): New procedures. * tests/lzlib.scm ("make-lzip-input-port/compressed"): New test. * guix/tests.scm (%seed): Export.
2019-05-06Add (guix lzlib).Pierre Neidhardt
* guix/lzlib.scm, tests/lzlib.scm: New files. * Makefile.am (MODULES): Add guix/lzlib.scm. (SCM_TESTS): Add tests/lzlib.scm. * m4/guix.m4 (GUIX_LIBLZ_LIBDIR): New macro. * configure.ac (LIBLZ_LIBDIR): Use it. Define and substitute 'LIBLZ'. * guix/config.scm.in (%liblz): New variable. * guix/self.scm (make-config.scm): Add TODO comment. Co-authored-by: Ludovic Courtès <ludo@gnu.org>