This patch was borrowed from Debian's package:
https://salsa.debian.org/multimedia-team/ableton-link/-/blob/9c65141bf5bba0872811c179af77ac95770352cc/debian/patches/DEBIAN_system_libraries.patch
Description: Drop dependencies on included 3rd-party libs
upstream includes git-submodules for Catch and ASIO (not found in the tarball).
on Debian we want to use the system provided libraries.
Author: IOhannes m zmölnig
Origin: Debian
Forwarded: not-needed
Last-Update: 2016-10-26
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- ableton-link.orig/cmake_include/AsioStandaloneConfig.cmake
+++ ableton-link/cmake_include/AsioStandaloneConfig.cmake
@@ -1,6 +1,2 @@
add_library(AsioStandalone::AsioStandalone IMPORTED INTERFACE)
-set_property(TARGET AsioStandalone::AsioStandalone APPEND PROPERTY
- INTERFACE_INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_LIST_DIR}/../modules/asio-standalone/asio/include
-)
--- ableton-link.orig/cmake_include/CatchConfig.cmake
+++ ableton-link/cmake_include/CatchConfig.cmake
@@ -1,6 +1,2 @@
add_library(Catch::Catch IMPORTED INTERFACE)
-set_property(TARGET Catch::Catch APPEND PROPERTY
- INTERFACE_INCLUDE_DIRECTORIES
- ${CMAKE_SOURCE_DIR}/third_party/catch
-)
='/guix/commit/m4?id=5c6bfdba55c17624b416b14ef267de07ee54a751'>commitdiff
|
Age | Commit message (Expand) | Author |
2024-12-03 | gnu: bootstrap: Add support for x86_64-gnu, aka the 64bit Hurd....On commit:
ec8a5ec15f898e864705e5a5c834532e3fa8d0a4
gnu: make-bootstrap: Update gcc-static to gcc-14, for the 64bit Hurd.
Run:
./pre-inst-env guix build --target=x86_64-gnu bootstrap-tarballs
Producing:
/gnu/store/w1n7bdpn88plcc49h7n0jriaj41sgwx8-bootstrap-tarballs-0/
With guix hash -r:
15cb1xh7s2hhp8s0d81bjnw1759w9sh7ckc9n5jq2f3rqw6z76by
* gnu/packages/bootstrap.scm (%bootstrap-executables): Add entries for
x86_64-gnu.
(%bootstrap-guile-hash, %bootstrap-coreutils&co, %bootstrap-binutils,
%bootstrap-glibc, %bootstrap-gcc): Add entry for x86_64-gnu.
* guix/packages.scm (%supported-systems, %hurd-systems): Add x86_64-gnu.
(%cuirass-supported-systems): Remove x86_64-gnu.
* guix/utils.scm (target-64bit?): Add x86_64-gnu.
* m4/guix.m4: Add x86_64-gnu as a supported system.
* doc/guix.texi (GNU Distribution): Add x86_64-gnu.
Change-Id: I828159aedb3f66caba98e935083cc3682429f219
| Janneke Nieuwenhuizen |
2023-11-07 | build: Fix spelling in m4 macros....* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Fix spelling of parameter.
(GUIX_CHECK_FILE_NAME_LIMITS): Fix spelling of maximum.
Change-Id: I93c80441393622a4bc06daa475eee13874cca527
| Efraim Flashner |
2023-03-16 | build: Correct guix_system on musl libc distros....* m4/guix.m4 (GUIX_SYSTEM_TYPE): Add linux-musl* case. This prevents
the macro from mis-parsing the host OS, which causes breakage when
building from source.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Antero Mejr |