This patch was borrowed from Debian's package:
https://salsa.debian.org/multimedia-team/ableton-link/-/blob/9c65141bf5bba0872811c179af77ac95770352cc/debian/patches/DEBIAN_system_libraries.patch
Description: Drop dependencies on included 3rd-party libs
upstream includes git-submodules for Catch and ASIO (not found in the tarball).
on Debian we want to use the system provided libraries.
Author: IOhannes m zmölnig
Origin: Debian
Forwarded: not-needed
Last-Update: 2016-10-26
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- ableton-link.orig/cmake_include/AsioStandaloneConfig.cmake
+++ ableton-link/cmake_include/AsioStandaloneConfig.cmake
@@ -1,6 +1,2 @@
add_library(AsioStandalone::AsioStandalone IMPORTED INTERFACE)
-set_property(TARGET AsioStandalone::AsioStandalone APPEND PROPERTY
- INTERFACE_INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_LIST_DIR}/../modules/asio-standalone/asio/include
-)
--- ableton-link.orig/cmake_include/CatchConfig.cmake
+++ ableton-link/cmake_include/CatchConfig.cmake
@@ -1,6 +1,2 @@
add_library(Catch::Catch IMPORTED INTERFACE)
-set_property(TARGET Catch::Catch APPEND PROPERTY
- INTERFACE_INCLUDE_DIRECTORIES
- ${CMAKE_SOURCE_DIR}/third_party/catch
-)
b9330d8b5b26a47a9a60d16713f62dd221c51ce'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2023-06-06 | services: Check if service is #f before applying clause....* gnu/services.scm (apply-clauses): Check if service is #f before trying to
apply clause. Follow up of 181951207339508789b28ba7cb914f983319920f.
| Josselin Poiret |
2023-06-06 | services: 'modify-services' preserves service ordering....Fixes <https://issues.guix.gnu.org/63921>.
The regression was introduced in
dbbc7e946131ba257728f1d05b96c4339b7ee88b, which changed the order of
services. As a result, someone using 'modify-services' could find
themselves with incorrect ordering of expressions in the "boot" script,
whereby the cleanup expressions would come after (execl ".../shepherd").
This, in turn, would lead shepherd to error out at boot with EADDRINUSE
on /var/run/shepherd/socket.
* gnu/services.scm (%delete-service, %apply-clauses): Remove.
(clause-alist): New macro.
(apply-clauses): New procedure.
(modify-services): Use it. Adjust docstring.
* tests/services.scm ("modify-services: do nothing"): Remove 'sort' call.
("modify-services: delete service"): Likewise, and add 't4' service.
("modify-services: change value"): Remove 'sort' call and fix expected value.
| Ludovic Courtès |
2023-06-02 | services: Error in MODIFY-SERVICES when services don't exist...This patch causes MODIFY-SERVICES to raise an error if a reference is made to
a service which isn't in its service list. This it to help users notice if
they have an invalid rule, which is currently silently ignored.
* gnu/services.scm (%delete-service): new procedure
(%apply-clauses): new syntax rule
(%modify-service): remove syntax rule
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Brian Cully |
2023-05-16 | services: Add default values....* gnu/services.scm (boot-service-type, activation-service-type,
etc-service-type, profile-service-type): Add default-value.
* gnu/system/shadow.scm (account-service-type): Add default-value.
| Andrew Tropin |
2023-03-16 | services: etc-service: Deprecate etc-service procedure....* gnu/services.scm (etc-service): Deprecate procedure.
* gnu/system.scm (operating-system-etc-service): Replace etc-service
with etc-service-type.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Bruno Victal |