The way the configure script determines the version of libwmf is by temporarily making dots separator characters, but since the file name of the program which returns the version contains dots in Guix (the version in the store entry name), doing it this way will always fail. This is a simple guix-specific fix for the problem. --- a/configure 2010-06-13 23:17:37.000000000 +0200 +++ b/configure 2014-09-08 17:31:52.102371800 +0200 @@ -21140,13 +21140,11 @@ $as_echo "$as_me: WARNING: wmf plugin: program libwmf-config not found in path" >&2;} fi else - IFS_old="$IFS" - IFS='.' - set -- `$libwmfconfig --version` - libwmf_major_found="${1}" - libwmf_minor_found="${2}" - libwmf_micro_found="${3}" - IFS="$IFS_old" + libwmf_fullver_found=`$libwmfconfig --version` + libwmf_major_found=$(echo $libwmf_fullver_found | cut -d . -f 1) + libwmf_minor_found=$(echo $libwmf_fullver_found | cut -d . -f 2) + libwmf_micro_found=$(echo $libwmf_fullver_found | cut -d . -f 3) + if test "$libwmf_major_found" -gt "$libwmf_major_req"; then wmf_deps="yes" elif test "$libwmf_major_found" -eq "$libwmf_major_req" && b35eb1d66f'>refslogtreecommitdiff
path: root/gnu/system/file-systems.scm
AgeCommit message (Expand)Author
2021-07-18pack: Streamline how files are included in tarballs....Maxim Cournoyer
2021-07-03file-systems: Ensure compared file names are both absolute or relative....Maxim Cournoyer
2021-06-29pack: Prevent duplicate files in tar archives....Maxim Cournoyer
2020-10-01Instantiate nscd in each system container....Jason Conroy
2020-08-03file-systems: Leave room for extension in serialized specs....Ludovic Courtès
2020-07-31file-system: Add efivarfs support....Mathieu Othacehe
2020-07-31file-system: Add mount-may-fail? option....Mathieu Othacehe
2020-07-31file-systems: Add %debug-file-system....Mathieu Othacehe
2020-07-25file-systems: Convey hint via '&fix-hint'....Ludovic Courtès
2020-05-20bootloader: grub: Allow booting from a Btrfs subvolume....Maxim Cournoyer
2020-05-20file-systems: Add helpers for parsing the options string into an alist....Maxim Cournoyer
2020-04-27file-systems: mount the PID cgroup filesystem....Jakub Kądziołka
2020-03-02file-systems: Add a 'file-system-device->string' procedure....Maxim Cournoyer
2019-11-04file-systems: Mount /var/run/nscd read-write in containers....Ludovic Courtès