;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Eric Bavier ;;; Copyright © 2015 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages nutrition) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system python) #:use-module (gnu packages) #:use-module (gnu packages gtk) #:use-module (gnu packages glib) #:use-module (gnu packages image) #:use-module (gnu packages python)) (define-public gourmet (package (name "gourmet") (version "0.17.4") (source (origin (method url-fetch) (uri (string-append "https://github.com/thinkle/gourmet/archive/" version ".tar.gz")) (file-name (string-append name "-" version ".tar.gz")) (sha256 (base32 "1qvz175arzqm10lpfx8ffadrgirs3240zzqcp0h7sl53qfwx7v8k")))) (build-system python-build-system) (native-inputs `(("distutils-extra" ,python2-distutils-extra) ("intltool" ,intltool) ("python-pygtk" ,python2-pygtk))) ;for tests ;; TODO: Add python-reportlab and/or python-poppler for printing/pdf ;; export, and python-beautifulsoup for web import plugin. (inputs `(("pygtk" ,python2-pygtk) ("sqlalchemy" ,python2-sqlalchemy) ("python-pillow" ,python2-pillow) ("elib.intl" ,python2-elib.intl))) (arguments `(#:python ,python-2 ;exception and print syntax #:tests? #f)) ;tests look bitrotted (home-page "http://thinkle.github.io/gourmet/") (synopsis "Recipe organizer") (description "Gourmet Recipe Manager is a recipe organizer that allows you to collect, search, organize, and browse your recipes. Gourmet can also generate shopping lists and calculate nutritional information. It imports Mealmaster, MasterCook and KRecipe files and exports PDFs, webpages, and other formats.") (license gpl2+))) >9space:mode:
author宋文武 <iyzsong@member.fsf.org>2017-10-05 17:42:17 +0800
committerLudovic Courtès <ludo@gnu.org>2017-10-19 12:17:44 +0200
commitb79813a19a8892c48bea1e0a9279265616be66d7 (patch)
treea5b7b1b629adf050b2a15f8b99325ea3b3a1dc15 /gnu
parent4ad8fbd1856d7169ff457b6627b6a1259ac48ebd (diff)
downloadguix-b79813a19a8892c48bea1e0a9279265616be66d7.tar.gz
guix-b79813a19a8892c48bea1e0a9279265616be66d7.zip
gnu: speex: Build and install 'speexdec' and 'speexenc'.
* gnu/packages/xiph.scm (speex)[native-inputs]: Add 'pkg-config'. [inputs]: Add 'speexdsp'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xiph.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 47274411b5..5565cb5563 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -139,7 +139,11 @@ compressed video format.")
(base32
"150047wnllz4r94whb9r73l5qf0z5z3rlhy98bawfbblmkq8mbpa"))))
(build-system gnu-build-system)
- (inputs `(("libogg" ,libogg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libogg" ,libogg)
+ ("speexdsp" ,speexdsp)))
(home-page "https://gnu.org/software/speex")
(synopsis "Library for patent-free audio compression format")
(description