;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Cyrill Schenkel ;;; Copyright © 2015 Andreas Enge ;;; Copyright © 2015, 2016 David Thompson ;;; Copyright © 2016 Ludovic Courtès ;;; Copyright © 2017 Mike Gerwitz ;;; Copyright © 2018 Tobias Geerinckx-Rice ;;; Copyright © 2018, 2019 Marius Bakke ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-06-09 18:10:20 +0800
committerMarius Bakke <mbakke@fastmail.com>2019-06-15 14:43:34 +0200
commitddd401d28fb09f1f8ce96f2fc24226887a812412 (patch)
tree43b2f33cc772f8b7c02bd2b0ecf8f546074a88fe /gnu/services/version-control.scm
parent24087364f5267409078aec3a749e3cabe485d91b (diff)
downloadguix-ddd401d28fb09f1f8ce96f2fc24226887a812412.tar.gz
guix-ddd401d28fb09f1f8ce96f2fc24226887a812412.zip
gnu: swayidle: Add elogind support.
* gnu/packages/wm.scm (swayidle)[arguments]: Add #:configure-flags. [inputs]: Add elogind. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/services/version-control.scm')
0 files changed, 0 insertions, 0 deletions
efix) configure-flags))) (format #t "build directory: ~s~%" (getcwd)) (format #t "configure flags: ~s~%" flags) ;; Node's configure script expects the CC environment variable to ;; be set. (setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc")) (apply invoke (string-append (assoc-ref inputs "python") "/bin/python") "configure" flags)))) (add-after 'patch-shebangs 'patch-npm-shebang (lambda* (#:key outputs #:allow-other-keys) (let* ((bindir (string-append (assoc-ref outputs "out") "/bin")) (npm (string-append bindir "/npm")) (target (readlink npm))) (with-directory-excursion bindir (patch-shebang target (list bindir)) #t))))))) (native-inputs `(("python" ,python-2) ("perl" ,perl) ("pkg-config" ,pkg-config) ("procps" ,procps) ("util-linux" ,util-linux) ("which" ,which))) (native-search-paths (list (search-path-specification (variable "NODE_PATH") (files '("lib/node_modules"))))) (inputs `(("c-ares" ,c-ares) ("http-parser" ,http-parser) ("icu4c" ,icu4c) ("libuv" ,libuv) ("nghttp2" ,nghttp2 "lib") ("openssl" ,openssl-next) ("zlib" ,zlib))) (synopsis "Evented I/O for V8 JavaScript") (description "Node.js is a platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications. Node.js uses an event-driven, non-blocking I/O model that makes it lightweight and efficient, perfect for data-intensive real-time applications that run across distributed devices.") (home-page "https://nodejs.org/") (license expat) (properties '((timeout . 3600))))) ; 1 h