;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 John Darrington ;;; Copyright © 2017, 2018 Leo Famulari ;;; Copyright © 2018 Efraim Flashner ;;; Copyright © 2020 Ricardo Wurmus ;;; Copyright © 2020 Tobias Geerinckx-Rice ;;; Copyright © 2020 Lars-Dominik Braun ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages nfs) #:use-module (gnu packages) #:use-module (gnu packages attr) #:use-module (gnu packages autotools) #:use-module (gnu packages crypto) #:use-module (gnu packages linux) #:use-module (gnu packages libevent) #:use-module (gnu packages kerberos) #:use-module (gnu packages onc-rpc) #:use-module (gnu packages pkg-config) #:use-module (gnu packages python) #:use-module (gnu packages sqlite) #:use-module (guix build-system gnu) #:use-module (guix download) #:use-module (guix git-download) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix utils) #:use-module (srfi srfi-1) #:use-module (srfi srfi-2) #:use-module (srfi srfi-26) #:use-module (ice-9 match)) (define-public nfs-utils (package (name "nfs-utils") (version "2.4.3") (source (origin (method url-fetch) (uri (string-append "mirror://kernel.org/linux/utils/nfs-utils/" version "/nfs-utils-" version ".tar.xz")) (sha256 (base32 "16b5y82cjy1cvijg5zmdvivc6sfdlv2slyynxbwwyw43vpjzqrdg")))) (build-system gnu-build-system) (arguments `(#:configure-flags `("--disable-static" "--without-tcp-wrappers" ,(string-append "--with-start-statd=" (assoc-ref %outputs "out") "/sbin/start-statd") ,(string-append "--with-krb5=" (assoc-ref %build-inputs "mit-krb5")) ,(string-append "--with-pluginpath=" (assoc-ref %outputs "out") "/lib/libnfsidmap") "--enable-svcgss") #:phases (modify-phases %standard-phases (add-before 'configure 'adjust-command-file-names (lambda _ ;; Remove assumptions of FHS from start-statd script (substitute* `("utils/statd/start-statd") (("^PATH=.*") "") (("^flock") (string-append (assoc-ref %build-inputs "util-linux") "/bin/flock")) (("^exec rpc.statd") (string-append "exec " (assoc-ref %outputs "out") "/sbin/rpc.statd"))) ;; find rpcgen (substitute* "configure" (("/usr/local/bin/rpcgen") (which "rpcgen"))) ;; This hook tries to write to /var ;; That needs to be done by a service too. (substitute* `("Makefile.in") (("^install-data-hook:") "install-data-hook-disabled-for-guix:")) ;; Replace some hard coded paths. (substitute* `("utils/nfsd/nfssvc.c") (("/bin/mount") (string-append (assoc-ref %build-inputs "util-linux") "/bin/mount"))) (substitute* `("utils/statd/statd.c") (("/usr/sbin/") (string-append (assoc-ref %outputs "out") "/sbin/"))) (substitute* `("utils/mount/Makefile.in" "utils/nfsdcld/Makefile.in" "utils/nfsdcltrack/Makefile.in") (("^sbindir = /sbin") (string-append "sbindir = " (assoc-ref %outputs "out") "/sbin"))) #t))))) (inputs `(("keyutils" ,keyutils) ("libevent" ,libevent) ("rpcsvc-proto" ,rpcsvc-proto) ;for 'rpcgen' ("sqlite" ,sqlite) ("lvm2" ,lvm2) ("util-linux" ,util-linux) ; only for above substitutions ("util-linux:lib" ,util-linux "lib") ; for libblkid ("mit-krb5" ,mit-krb5) ("libtirpc" ,libtirpc) ("python-wrapper" ,python-wrapper))) ;for the Python based tools (native-inputs (list pkg-config)) (home-page "https://www.kernel.org/pub/linux/utils/nfs-utils/") (synopsis "Tools for loading and managing Linux NFS mounts") (description "The Network File System (NFS) was developed to allow machines to mount a disk partition on a remote machine as if it were a local disk. It allows for fa-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dbbe794295..3cb69d26ab 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1570,3 +1570,31 @@ somewhat intelligeble.")
(define-public python2-unidecode
(package-with-python2 python-unidecode))
+
+(define-public python-pyjwt
+ (package
+ (name "python-pyjwt")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/P/PyJWT/PyJWT-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ahqblfy2sj3xz34wsa48cn9rp0dspzq56p54i5znmws3b8gml6g"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ '(#:tests