;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ncdu) #:use-module (gnu packages) #:use-module (gnu packages ncurses) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public ncdu (package (name "ncdu") (version "1.14") (source (origin (method url-fetch) (uri (string-append "https://dev.yorhel.nl/download/ncdu-" version ".tar.gz")) (sha256 (base32 "0i4cap2z3037xx2rdzhrlazl2igk3xy4ncddp9j7xqi1mcx7i566")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (synopsis "Ncurses based disk usage analyzer") (description "A disk usage analyzer with an ncurses interface, aimed to be run on a remote server where you don't have an entire graphical setup, but have to do with a simple SSH connection. ncdu aims to be fast, simple and easy to use, and should be able to run in any minimal POSIX-like environment with ncurses installed.") (license (x11-style (string-append "https://g.blicky.net/ncdu.git/plain/COPYING?id=v" version))) (home-page "https://dev.yorhel.nl/ncdu"))) ot/tests/hackage.scm
AgeCommit message (Expand)Author
2019-06-20import: hackage: Add two expected failing test cases....Robert Vollmert
2019-06-13import: hackage: Handle Hackage revisions....Robert Vollmert
2019-06-02import: hackage: Parse braced properties....Robert Vollmert
2019-06-02tests: hackage: Test multiline cabal description....Robert Vollmert
2019-06-02tests: Fix hackage tests....Robert Vollmert
2019-06-01tests: Indent hackage tests...Robert Vollmert
2019-06-01tests: hackage: Don't mock hackage-fetch....Robert Vollmert
2019-06-01tests: hackage: Factor out package pattern....Robert Vollmert
2019-05-26import: hackage: Fix Cabal test....Ludovic Courtès
2018-07-12import: hackage: Evaluate "-any" and "-none" version comparison operators....Danny Milosavljevic
2016-09-01tests: hackage: Fix mock urls....Efraim Flashner
2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin
2015-11-26import: hackage: Add new tests....Federico Beffa
2015-06-09import: hackage: Refactor parsing code and add new options....Federico Beffa
2015-04-08import: Add hackage importer....Federico Beffa