;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ncdu) #:use-module (gnu packages) #:use-module (gnu packages ncurses) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public ncdu (package (name "ncdu") (version "1.14") (source (origin (method url-fetch) (uri (string-append "https://dev.yorhel.nl/download/ncdu-" version ".tar.gz")) (sha256 (base32 "0i4cap2z3037xx2rdzhrlazl2igk3xy4ncddp9j7xqi1mcx7i566")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (synopsis "Ncurses based disk usage analyzer") (description "A disk usage analyzer with an ncurses interface, aimed to be run on a remote server where you don't have an entire graphical setup, but have to do with a simple SSH connection. ncdu aims to be fast, simple and easy to use, and should be able to run in any minimal POSIX-like environment with ncurses installed.") (license (x11-style (string-append "https://g.blicky.net/ncdu.git/plain/COPYING?id=v" version))) (home-page "https://dev.yorhel.nl/ncdu"))) 83b698c4f6f50a2ce4daaef5f1de83f'>root/gnu/packages/ebook.scm
AgeCommit message (Expand)Author
2023-08-15gnu: fbreader: Fix icon.Danny Milosavljevic
2023-07-16gnu: xchm: Update to 1.35.Tobias Geerinckx-Rice
2023-04-03gnu: calibre: Update to 5.44.0.Andreas Enge
2023-04-03gnu: calibre: Fix build.Andreas Enge
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2023-02-17gnu: Make nothing depend on QtWebKit.Leo Famulari
2023-01-04gnu: hunspell: Move hunspell and dictionaries to hunspell module.Brian Cully
2022-11-28gnu: calibre: Add missing python-pycryptodome dependency.Andrew Tropin
2022-11-20gnu: inkbox: Fix build.Marius Bakke
2022-11-20gnu: inkbox: Update home-page and source URI.Marius Bakke
2022-09-16gnu: Add shirah.M
2022-09-16gnu: Add python-ebooklib.M
2022-08-21gnu: cozy: Update to 1.2.1.Vinicius Monego
2022-07-31gnu: qtwebengine: Rename to qtwebengine-5.Maxim Cournoyer
2022-07-31gnu: qtsvg: Rename variable to qtsvg-5.Maxim Cournoyer
2022-02-19gnu: calibre: Improve package style.Nicolas Goaziou
2022-02-19gnu: calibre: Remove input labels.Brendan Tildesley
2022-02-19gnu: calibre: Update to 5.36.0.Brendan Tildesley
2022-02-13gnu: cozy: Update to 1.2.0.Vinicius Monego