;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2015, 2016, 2017 Efraim Flashner ;;; Copyright © 2016 Rene Saavedra ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages nano) #:use-module (guix licenses) #:use-module (gnu packages gettext) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public nano (package (name "nano") (version "2.9.0") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/nano/nano-" version ".tar.xz")) (sha256 (base32 "17hjgvig59a2ha2b0494bprrci3d33sayjqvxjhsnlzgr8whrlyj")))) (build-system gnu-build-system) (inputs `(("gettext" ,gettext-minimal) ("ncurses" ,ncurses))) (home-page "https://www.nano-editor.org/") (synopsis "Small, user-friendly console text editor") (description "GNU nano is a small and simple text editor for use in a terminal. Besides basic editing, it supports: undo/redo, syntax highlighting, spell checking, justifying, auto-indentation, bracket matching, interactive search-and-replace (with regular expressions), and the editing of multiple files.") (license gpl3+))) ; some files are under GPLv2+ g/?id=692cce52cafd5477056835fd01f7b283afeace46'>root/gnu/packages/rocm.scm
AgeCommit message (Expand)Author
2021-09-10gnu: llvm-for-rocm: Move to llvm.scm....Ludovic Courtès
2021-08-27gnu: ocl-icd: Replace with opencl-icd-loader....Lars-Dominik Braun
2021-08-11gnu: rocm-opencl-runtime: Shorten patch file name....Ludovic Courtès
2021-08-11gnu: rocm-opencl-runtime: Use a non-redirecting source URL....Ludovic Courtès
2021-08-09gnu: rocminfo: Add description....Lars-Dominik Braun
2021-08-09gnu: rocminfo: Static references to lsmod and grep....Lars-Dominik Braun
2021-08-08gnu: Add rocm-bandwidth-test....Lars-Dominik Braun
2021-08-08gnu: Add rocminfo....Lars-Dominik Braun
2021-08-08gnu: Add rocm-opencl-runtime....Lars-Dominik Braun
2021-08-08gnu: Add rocclr....Lars-Dominik Braun
2021-08-08gnu: Add rocr-runtime....Lars-Dominik Braun
2021-08-08gnu: Add roct-thunk-interface....Lars-Dominik Braun
2021-08-08gnu: Add rocm-comgr....Lars-Dominik Braun
2021-08-08gnu: Add rocm-device-libs....Lars-Dominik Braun
2021-08-08gnu: Add llvm-for-rocm....Lars-Dominik Braun
2021-08-08gnu: Add rocm-cmake....Lars-Dominik Braun