;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner ;;; Copyright © 2016 Rene Saavedra ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages nano) #:use-module (guix licenses) #:use-module (gnu packages gettext) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public nano (package (name "nano") (version "4.9") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/nano/nano-" version ".tar.xz")) (sha256 (base32 "19ik88b3g0d9xwav4hkai2h1acmjy5fdnh21gdc1mjq5s4lrff8f")))) (build-system gnu-build-system) (inputs `(("gettext" ,gettext-minimal) ("ncurses" ,ncurses))) (home-page "https://www.nano-editor.org/") (synopsis "Small, user-friendly console text editor") (description "GNU nano is a small and simple text editor for use in a terminal. Besides basic editing, it supports: undo/redo, syntax highlighting, spell checking, justifying, auto-indentation, bracket matching, interactive search-and-replace (with regular expressions), and the editing of multiple files.") (license gpl3+))) ; some files are under GPLv2+ /tests?id=5cdb25c6866014b2c7a7bca64c07712f328486f5'>tests/hackage.scm
AgeCommit message (Expand)Author
2019-06-20import: hackage: Add two expected failing test cases....Robert Vollmert
2019-06-13import: hackage: Handle Hackage revisions....Robert Vollmert
2019-06-02import: hackage: Parse braced properties....Robert Vollmert
2019-06-02tests: hackage: Test multiline cabal description....Robert Vollmert
2019-06-02tests: Fix hackage tests....Robert Vollmert
2019-06-01tests: Indent hackage tests...Robert Vollmert
2019-06-01tests: hackage: Don't mock hackage-fetch....Robert Vollmert
2019-06-01tests: hackage: Factor out package pattern....Robert Vollmert
2019-05-26import: hackage: Fix Cabal test....Ludovic Courtès
2018-07-12import: hackage: Evaluate "-any" and "-none" version comparison operators....Danny Milosavljevic
2016-09-01tests: hackage: Fix mock urls....Efraim Flashner