;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner ;;; Copyright © 2016 Rene Saavedra ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages nano) #:use-module (guix licenses) #:use-module (gnu packages gettext) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public nano (package (name "nano") (version "5.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/nano/nano-" version ".tar.xz")) (sha256 (base32 "1sc6xl9935k9s9clkv83hapijka4qknfnj6f15c3b1i2n84396gy")))) (build-system gnu-build-system) (inputs `(("gettext" ,gettext-minimal) ("ncurses" ,ncurses))) (home-page "https://www.nano-editor.org/") (synopsis "Small, user-friendly console text editor") (description "GNU nano is a small and simple text editor for use in a terminal. Besides basic editing, it supports: undo/redo, syntax highlighting, spell checking, justifying, auto-indentation, bracket matching, interactive search-and-replace (with regular expressions), and the editing of multiple files.") (license gpl3+))) ; some files are under GPLv2+ 62214a1350761b'>gnu/installer
AgeCommit message (Expand)Author
2019-03-27services: Deprecate 'xfce-desktop-service'....Ludovic Courtès
2019-03-27services: Deprecate 'gnome-desktop-service'....Ludovic Courtès
2019-03-27installer: Use the (service …) form for MATE....Ludovic Courtès
2019-03-27installer: Ask for confirmation before formatting partitions....Ludovic Courtès
2019-03-27installer: Produce an 'initrd-modules' field if needed....Ludovic Courtès
2019-03-27installer: Emit 'bootloader' field before 'swap-devices'....Ludovic Courtès
2019-03-25installer: Set the system's 'keyboard-layout' field....Ludovic Courtès
2019-03-13installer: network: Adjust wording....Ludovic Courtès
2019-03-13Remove traces of "GuixSD"....Ludovic Courtès
2019-02-18gnu: Remove unused TIMEZONE-LISTBOX-HEIGTH....Tobias Geerinckx-Rice
2019-02-18gnu: Fix some typos in the installer....Tobias Geerinckx-Rice