;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Vincent Legoll ;;; Copyright © 2016 Ricardo Wurmus ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages musl) #:use-module (guix download) #:use-module (guix packages) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages)) (define-public musl (package (name "musl") (version "1.2.0") (source (origin (method url-fetch) (uri (string-append "https://www.musl-libc.org/releases/" "musl-" version ".tar.gz")) (sha256 (base32 "1s6lix02k1ijm4nmhzpmwzk5w6xfkhn70nvvk8zjs51r24cpppn6")))) (build-system gnu-build-system) (arguments `(#:tests? #f ; musl has no tests #:configure-flags (list "--disable-gcc-wrapper"))) (synopsis "Small C standard library") (description "musl is a simple and lightweight C standard library. It strives to be correct in the sense of standards-conformance and safety.") (home-page "https://musl.libc.org") ;; Musl as a whole is released under the Expat license. Parts of it are ;; derived from various third-party projects that are released under ;; non-copyleft licenses. See the COPYRIGHT file for details. (license license:expat))) 7ad9599b1ba506c1ec4a'>gnu/packages/gps.scm
AgeCommit message (Expand)Author
2020-03-11gnu: gpxsee: Extend description....Tobias Geerinckx-Rice
2020-03-11gnu: gpxsee: Update to 7.25....Tobias Geerinckx-Rice
2020-03-04gnu: Add gpsd....Guillaume Le Vaillant
2019-10-30gnu: gpxsee: Update to 7.16....Tobias Geerinckx-Rice
2019-10-01Merge branch 'master' into core-updatesLudovic Courtès
2019-09-28gnu: gpxsee: Update to 7.12....Tobias Geerinckx-Rice
2019-09-06Merge branch 'master' into core-updatesMark H Weaver
2019-09-05gnu: gama: Update to 2.07....Efraim Flashner
2019-07-31gnu: gpsbabel: Remove GCC 5 workaround....Marius Bakke
2019-07-08gnu: gama: Update to 2.06....Efraim Flashner
2019-06-13gnu: gpxsee: Fetch from Git instead of a generated tarball....Ludovic Courtès
2019-06-13gnu: gpxsee: Upgrade to 7.8...Nikolay Korotkiy
2019-05-13gnu: gpscorrelate: Update home page....Marius Bakke