;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Vincent Legoll ;;; Copyright © 2016 Ricardo Wurmus ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages musl) #:use-module (guix download) #:use-module (guix packages) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages)) (define-public musl (package (name "musl") (version "1.1.21") (source (origin (method url-fetch) (uri (string-append "https://www.musl-libc.org/releases/" "musl-" version ".tar.gz")) (sha256 (base32 "0i2z52zgc86af1n1gjiz43hgd85mxjgvgn345zsybja9dxpvchn7")))) (build-system gnu-build-system) (arguments `(#:tests? #f ; musl has no tests #:configure-flags (list "--disable-gcc-wrapper"))) (synopsis "Small C standard library") (description "musl is a simple and lightweight C standard library. It strives to be correct in the sense of standards-conformance and safety.") (home-page "https://www.musl-libc.org") ;; Musl as a whole is released under the Expat license. Parts of it are ;; derived from various third-party projects that are released under ;; non-copyleft licenses. See the COPYRIGHT file for details. (license license:expat))) a>/services.scm
AgeCommit message (Expand)Author
2020-12-01services: profile: Create manifest at monadic-bind time....Ludovic Courtès
2020-10-16services: provenance: Wrap config file name in 'assume-valid-file-name'....Ludovic Courtès
2020-08-25Remove "guile-zlib" extension when unused....Mathieu Othacehe
2020-08-25linux-libre: Support module compression....Mathieu Othacehe
2020-07-27machine: ssh: Check for potential system downgrades....Ludovic Courtès
2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès
2020-07-15services: Add 'system-provenance' procedure....Ludovic Courtès
2020-07-01services: provenance: Save channel introductions....Ludovic Courtès
2020-06-08gnu: services: Add %hurd-startup-service....Jan (janneke) Nieuwenhuizen
2020-06-08system: examples: Add bare-hurd.tmpl....Jan (janneke) Nieuwenhuizen
2020-04-26services: system: Initial entries are non-monadic....Ludovic Courtès
2020-04-26services: profile: Use a declarative profile....Ludovic Courtès
2020-04-21services: etc: Detect and report duplicate entries....Ludovic Courtès
2020-04-05services: Allow modprobe to use "/etc/modprobe.d"....Brice Waegeneire
2020-04-02services: Accumulate builds for 'system' entries....Ludovic Courtès