;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Vincent Legoll ;;; Copyright © 2016 Ricardo Wurmus ;;; Copyright © 2018–2020, 2022 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages musl) #:use-module (guix download) #:use-module (guix packages) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages)) (define-public musl (package (name "musl") (version "1.2.3") (source (origin (method url-fetch) (uri (string-append "https://www.musl-libc.org/releases/" "musl-" version ".tar.gz")) (sha256 (base32 "196lrzw0qy5axiz9p5ay50q2mls8hbfckr4rw0klc7jjc9h0nnvx")))) (build-system gnu-build-system) (arguments `(#:tests? #f ; musl has no tests #:configure-flags (list "--disable-gcc-wrapper"))) (synopsis "Small C standard library") (description "musl is a simple and lightweight C standard library. It strives to be correct in the sense of standards-conformance and safety.") (home-page "https://musl.libc.org") ;; Musl as a whole is released under the Expat license. Parts of it are ;; derived from various third-party projects that are released under ;; non-copyleft licenses. See the COPYRIGHT file for details. (license license:expat))) b51dba50b4d5'>gnu/packages/gd.scm
AgeCommit message (Expand)Author
2020-04-08gnu: perl-gd: Do not rely on 'libgd-config'.Marius Bakke
2020-03-26gnu: gd: Update to 2.3.0.Marius Bakke
2020-03-14Merge branch 'master' into core-updatesMarius Bakke
2020-03-11gnu: gd: Use HTTPS home page.Tobias Geerinckx-Rice
2020-01-22gnu: Replace uses of 'libjpeg' with 'libjpeg-turbo'.Marius Bakke
2020-01-08gnu: gd: Do not build static library.Marius Bakke
2019-03-23Merge branch 'staging' into core-updatesMarius Bakke
2019-03-14gnu: perl-gd-securityimage: Update to 1.75.Tobias Geerinckx-Rice
2019-03-14gnu: perl-gd: Update to 2.71.Tobias Geerinckx-Rice
2019-02-23gnu: gd: Incorporate grafted changes.Marius Bakke
2019-02-19gnu: libgd: Fix CVE-2019-{6977,6978}.Leo Famulari
2018-11-14gnu: perl: Return #t from all phases.Mark H Weaver
2018-09-10gnu: libgd: Incorporate grafted changes.Marius Bakke
2018-09-09gnu: libgd: Fix CVE-2018-{5711,1000222}.Leo Famulari
2018-08-30gnu: perl-gd: Update to 2.69.Tobias Geerinckx-Rice
2018-08-11Migrate search.cpan.org home pages to metacpan.org.Tobias Geerinckx-Rice
2018-02-27gnu: perl-gd: Update to 2.68.Tobias Geerinckx-Rice