;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Vincent Legoll ;;; Copyright © 2016 Ricardo Wurmus ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages musl) #:use-module (guix download) #:use-module (guix packages) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages)) (define-public musl (package (name "musl") (version "1.1.15") (source (origin (method url-fetch) (uri (string-append "http://www.musl-libc.org/releases/" name "-" version ".tar.gz")) (sha256 (base32 "1ymhxkskivzph0q34zadwfglc5gyahqajm7chqqn2zraxv3lgr4p")))) (build-system gnu-build-system) (arguments `(#:tests? #f ; Musl has no tests #:configure-flags (list "--disable-gcc-wrapper"))) (synopsis "Small C standard library") (description "musl is a simple and lightweight C standard library. It strives to be correct in the sense of standards-conformance and safety.") (home-page "http://www.musl-libc.org") ;; Musl as a whole is released under the Expat license. Parts of it are ;; derived from various third-party projects that are released under ;; non-copyleft licenses. See the COPYRIGHT file for details. (license license:expat))) 919ba4976ec20bbfbd14587e87c4780653226'>doc/images
AgeCommit message (Expand)Author
2019-03-14Merge branch 'staging' into core-updatesMarius Bakke
2019-03-13doc: Document the graphical installer some more....Ludovic Courtès
2018-12-16doc: Update mesboot graph without bootstrap-guile....Jan Nieuwenhuizen
2018-11-24doc: Update for bootstrap-mescc-tools change....Jan Nieuwenhuizen
2018-09-23doc: Describe the Reduced Binary Seed bootstrap....Jan Nieuwenhuizen
2016-12-17doc: Update dot graphs....Ludovic Courtès
2016-01-29guix system: Rename 'dmd-graph' to 'shepherd-graph'....Alex Kost
2016-01-29services: Rename 'dmd' services to 'shepherd'....Alex Kost
2016-01-12doc: Show bootstrapping at the package level....Ludovic Courtès
2015-11-02services: Add 'profile-service-type'....Ludovic Courtès
2015-11-02services: Add 'system-service-type'....Ludovic Courtès
2015-10-15doc: Regenerate 'guix graph' examples....Ludovic Courtès
2015-10-14guix system: Add 'dmd-graph' command....Ludovic Courtès
2015-10-10services: Introduce extensible services....Ludovic Courtès
2015-08-27Add 'guix graph'....Ludovic Courtès
2015-06-21size: Add '--map-file' option....Ludovic Courtès