;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Vincent Legoll ;;; Copyright © 2016 Ricardo Wurmus ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages musl) #:use-module (guix download) #:use-module (guix packages) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages)) (define-public musl (package (name "musl") (version "1.2.0") (source (origin (method url-fetch) (uri (string-append "https://www.musl-libc.org/releases/" "musl-" version ".tar.gz")) (sha256 (base32 "1s6lix02k1ijm4nmhzpmwzk5w6xfkhn70nvvk8zjs51r24cpppn6")))) (build-system gnu-build-system) (arguments `(#:tests? #f ; musl has no tests #:configure-flags (list "--disable-gcc-wrapper"))) (synopsis "Small C standard library") (description "musl is a simple and lightweight C standard library. It strives to be correct in the sense of standards-conformance and safety.") (home-page "https://musl.libc.org") ;; Musl as a whole is released under the Expat license. Parts of it are ;; derived from various third-party projects that are released under ;; non-copyleft licenses. See the COPYRIGHT file for details. (license license:expat))) ref='/guix/log/gnu?id=8f0069170c261642fd0b3128c3eb194e4ba2efca'>gnu/packages/telephony.scm
AgeCommit message (Expand)Author
2017-03-01gnu: mumble: Build with 'murmur' server component....ng0
2017-02-10gnu: librstp: Allow tests to run....Ludovic Courtès
2017-02-01gnu: mumble: Update to 1.2.19....Marius Bakke
2016-12-18gnu: mumble: Update to 1.2.18....Marius Bakke
2016-12-13gnu: libsrtp: Fix building on mips....Efraim Flashner
2016-12-13gnu: libsrtp: Have source use file-name....Efraim Flashner
2016-11-26gnu: Add mumble....ng0
2016-11-19gnu: Use 'mirror://' URLs in several places....Ludovic Courtès
2016-09-28gnu: telephony: Add 'license:' prefix....Lukas Gradl
2016-08-02gnu: Add Seren....Francesco Frassinelli
2016-06-01gnu: Add libiax2....Lukas Gradl
2016-04-15gnu-maintenance: Move FTP directory info to 'properties' fields....Ludovic Courtès
2016-04-03gnu: libsrtp: Update to 1.5.4 [fixes CVE-2015-6360]....Leo Famulari
2015-12-22gnu: sipwitch: Update to 1.9.15....Efraim Flashner
2015-12-22gnu: ucommon: Update to 7.0.0....Efraim Flashner
2015-11-04gnu: sipwitch: Update to 1.9.14....Efraim Flashner
2015-11-04gnu: ucommon: Update to 6.6.2....Efraim Flashner