;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Vincent Legoll ;;; Copyright © 2016 Ricardo Wurmus ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages musl) #:use-module (guix download) #:use-module (guix packages) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages)) (define-public musl (package (name "musl") (version "1.1.22") (source (origin (method url-fetch) (uri (string-append "https://www.musl-libc.org/releases/" "musl-" version ".tar.gz")) (sha256 (base32 "1qr9xqdzziy5bsyyqlh6k8yz056ll55d5yvc0gbhz61ginj422cb")))) (build-system gnu-build-system) (arguments `(#:tests? #f ; musl has no tests #:configure-flags (list "--disable-gcc-wrapper"))) (synopsis "Small C standard library") (description "musl is a simple and lightweight C standard library. It strives to be correct in the sense of standards-conformance and safety.") (home-page "https://www.musl-libc.org") ;; Musl as a whole is released under the Expat license. Parts of it are ;; derived from various third-party projects that are released under ;; non-copyleft licenses. See the COPYRIGHT file for details. (license license:expat))) 77d0cddbcd8bb85c06fd2249f2d9c4ccd27'>gnu/services/mcron.scm
span>
AgeCommit message (Expand)Author
2019-06-15services: Remove unneeded imports that led to cycles....Ludovic Courtès
2019-05-12services: mcron: Log to a file....Christopher Baines
2019-01-28gnu: Move most packages from guile.scm to new module....Ricardo Wurmus
2019-01-11services: Deprecate a few more service procedures....Ludovic Courtès
2018-11-13services: mcron: Fix typo in comment....Ludovic Courtès
2018-07-13services: mcron: Add 'schedule' action....Ludovic Courtès
2018-03-19gnu: mcron: Update to 1.1 and deprecate "mcron2"....Ludovic Courtès
guix system: Add 'dmd-graph' command....Ludovic Courtès
2015-10-10services: Introduce extensible services....Ludovic Courtès
2015-08-27Add 'guix graph'....Ludovic Courtès
2015-06-21size: Add '--map-file' option....Ludovic Courtès
2013-07-07doc: Add a "Boostrapping" section....Ludovic Courtès