;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2015, 2017 Eric Bavier ;;; Copyright © 2016, 2019, 2021, 2023 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages moe) #:use-module ((guix licenses) #:select (gpl2+)) #:use-module (gnu packages ncurses) #:use-module (gnu packages compression) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public moe (package (name "moe") (version "1.13") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/moe/moe-" version ".tar.lz")) (sha256 (base32 "0sql4r5g60k3rsz8vsr04rl5b873rwli1x75333xd29ga6y5g9a3")))) (build-system gnu-build-system) (native-inputs (list lzip)) (inputs (list ncurses)) (home-page "https://www.gnu.org/software/moe/moe.html") (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor") (description "GNU Moe is a powerful-but-simple-to-use text editor. It works in a modeless manner, and features an intuitive set of key-bindings that assign a degree of severity to each key; for example, key combinations with the Alt key are for harmless commands like cursor movements while combinations with the Control key are for commands that will modify the text. Moe features multiple windows, unlimited undo/redo, unlimited line length, global search and replace, and more.") (license gpl2+))) 74a2fe'>gnu/packages/swig.scm
AgeCommit message (Expand)Author
2020-03-18gnu: swig: Use guile-3.0 instead of guile-2.2....Arun Isaac
2019-12-12gnu: swig: Build with guile-2.2....Efraim Flashner
2019-12-05gnu: swig: Update to 4.0.1....Marius Bakke
2019-12-01gnu: swig.scm: Sort module inputs alphabetically....Efraim Flashner
2019-12-01gnu: swig: Clean up inputs....Efraim Flashner
2019-11-15gnu: swig: Fix cross-compilation....Mathieu Othacehe
2019-02-09gnu: swig: Fix FTBFS with GCC >= 6....Marius Bakke
2018-10-18gnu: swig: Fix build on i686....Marius Bakke
2018-05-30Revert "gnu: swig: Patch for Octave 4.4."...Mark H Weaver
2018-05-29gnu: swig: Patch for Octave 4.4....Kei Kebreau
2017-06-14