;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2015, 2017 Eric Bavier ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages moe) #:use-module ((guix licenses) #:select (gpl3+)) #:use-module (gnu packages ncurses) #:use-module (gnu packages compression) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public moe (package (name "moe") (version "1.9") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/moe/moe-" version ".tar.lz")) (sha256 (base32 "1wsfzy0iia0c89wnx1ilzw54wqcmlp2nz8mkpvc393z0zagrx48q")))) (build-system gnu-build-system) (native-inputs `(("lzip" ,lzip))) (inputs `(("ncurses" ,ncurses))) (home-page "https://www.gnu.org/software/moe/moe.html") (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor") (description "GNU Moe is a powerful-but-simple-to-use text editor. It works in a modeless manner, and features an intuitive set of key-bindings that assign a degree of severity to each key; for example, key combinations with the Alt key are for harmless commands like cursor movements while combinations with the Control key are for commands that will modify the text. Moe features multiple windows, unlimited undo/redo, unlimited line length, global search and replace, and more.") (license gpl3+))) da295ea9d27eb16d'>gnu/packages/docker.scm
AgeCommit message (Expand)Author
2022-07-13services: docker: Fix race condition....Oleg Pykhalov
2022-06-23gnu: docker: Honor TESTS? and please guix lint....Maxim Cournoyer
2022-06-23gnu: docker: Switch to gexp and new input style....Pierre Langlois
2022-06-23gnu: docker: Update to 20.10.17....Pierre Langlois
2022-06-23gnu: docker: Fix mkfs.xfs reference....Pierre Langlois
2022-06-23gnu: containerd: Switch to gexp arguments....Pierre Langlois
2022-06-23gnu: containerd: Update to 1.6.6....Pierre Langlois
2022-06-23gnu: containerd: Fix patch-paths build phase....Pierre Langlois
2022-04-27gnu: docker-compose: Use python-pyyaml@5....zimoun
2022-01-12gnu: python-websocket-client: Update to 1.2.3....Marius Bakke
2022-01-05gnu: cqfd: Update to 5.3.0....Maxim Cournoyer
2021-12-24build-system/go: Use go-1.17 by default....Sarah Morgensen
2021-12-13gnu: Simplify package inputs....Ludovic Courtès
2021-11-11gnu: docker-compose: Update to 1.29.2....Maxim Cournoyer
2021-11-11gnu: python-docker: Update to 5.0.3 and remove obsolete package variants....Maxim Cournoyer
2021-06-10gnu: docker: Replace tini by tini-static....Maxim Cournoyer
2021-06-10gnu: tini: Update to 0.19.0 and provide tini-static....Maxim Cournoyer