;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 John Darrington ;;; Copyright © 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages microcom) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix git-download) #:use-module (guix download) #:use-module (gnu packages autotools) #:use-module (gnu packages readline) #:use-module (guix build-system gnu)) (define-public microcom (package (name "microcom") (version "2019.01.0") (source (origin (method git-fetch) (uri (git-reference (url "https://git.pengutronix.de/git/tools/microcom.git") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0rf4qdkbhknrrqn4rpb737l0km8yn5f498zapks4akf6yjh5aq8y")))) (build-system gnu-build-system) (inputs (list readline)) (native-inputs (list automake autoconf)) (home-page "https://git.pengutronix.de/?p=tools/microcom.git") (synopsis "Minimalistic serial line terminal program") (description "Microcom is a minimalistic terminal program for accessing devices via a serial connection. It features connection via RS232 serial interfaces (including setting of transfer rates) as well as in @code{telnetmode} as specified in rfc2217 and a (Linux specific) CAN mode.") (license gpl2+))) 5b5c0612065d3361ebf35f0c2'>gnu/installer.scm
AgeCommit message (Expand)Author
2022-08-08installer: Render the final configuration with (guix read-print)....Ludovic Courtès
2022-02-02installer: Use system-wide guix for system init....Josselin Poiret
2022-02-02installer: Make dump archive creation optional and selective....Josselin Poiret
2022-02-02installer: Use dynamic-wind to setup installer....Josselin Poiret
2022-02-02installer: Add nano to PATH....Josselin Poiret
2022-02-02installer: Add installer-specific run command process....Josselin Poiret
2022-02-02installer: Use new installer-log-line everywhere....Josselin Poiret
2022-02-02installer: Use define instead of let at top-level....Josselin Poiret
2022-02-02installer: Add crash dump upload support....Mathieu Othacehe
2022-01-14installer: Check if ci.guix.gnu.org can be reached....Mathieu Othacehe
2021-09-23installer: Support XFS....Tobias Geerinckx-Rice