;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 John Darrington ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages microcom) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix git-download) #:use-module (guix download) #:use-module (gnu packages autotools) #:use-module (gnu packages readline) #:use-module (guix build-system gnu)) (define-public microcom (package (name "microcom") (version "2016.01.09") (source (origin (method git-fetch) (uri (git-reference (url "https://git.pengutronix.de/git/tools/microcom.git") (commit "v2016.01.0"))) (file-name (string-append name "-" version "-checkout")) (sha256 (base32 "080ci5589bpyy5kcl51csmvpw9zysify189hw6awx69pi3cjnxly")))) (build-system gnu-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-after 'unpack 'bootstrap (lambda _ (zero? (system* "autoreconf" "-i"))))))) (inputs `(("readline" ,readline))) (native-inputs `(("automake" ,automake) ("autoconf" ,autoconf))) (home-page "http://git.pengutronix.de/?p=tools/microcom.git") (synopsis "Minimalistic serial line terminal program") (description "Microcom is a minimalistic terminal program for accessing devices via a serial connection. It features connection via RS232 serial interfaces (including setting of transfer rates) as well as in `telnetmode' as specified in rfc2217 and a (Linux specific) CAN mode.") (license gpl2+))) g=1'>gnu/packages/tmux.scm
AgeCommit message (Collapse)Author
2017-07-05gnu: tmux: Update to 2.5.Stefan Reichör
* gnu/packages/tmux.scm (tmux): Update to 2.5. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
2017-06-17gnu: Add tmuxifier.Stefan Reichoer
* gnu/packages/tmux.scm (tmuxifier): New variable. Signed-off-by: Thomas Danckaert <post@thomasdanckaert.be>
2017-04-21gnu: tmux: Update to 2.4.Vasile Dumitrascu
* gnu/packages/tmux.scm (tmux): Update to 2.4. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2016-09-30gnu: tmux: Update to 2.3.Leo Famulari
* gnu/packages/tmux.scm (tmux): Update to 2.3.
2016-07-10gnu: Add Tmux Themepack.Matthew Jordan
* gnu/packages/tmux.scm (tmux-themepack): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
2016-05-16gnu: tmux: Update to 2.2.Efraim Flashner
* gnu/packages/tmux.scm (tmux): Update to 2.2.