;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2020 Brett Gilio ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages mercury) #:use-module (guix download) #:use-module (guix git-download) #:use-module (guix packages) #:use-module (guix utils) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix build-system gnu) #:use-module (gnu packages autotools) #:use-module (gnu packages bdw-gc) #:use-module (gnu packages readline) #:use-module (gnu packages texinfo) #:use-module (gnu packages flex) #:use-module (gnu packages shells) #:use-module (gnu packages bison) #:use-module (gnu packages pkg-config) #:use-module ((ice-9 match) #:select (match-lambda))) ;; NOTE: Mercury uses a tightly coupled fork of BDWGC and ;; libatomic-ops. When updating the package, please check the GitHub ;; repository to ensure that the submodule commit matches what is ;; provided. (define (gc-fork package-name package-url package-commit package-hash) (let ((commit package-commit)) (package (inherit package-name) (source (origin (method git-fetch) (uri (git-reference (url package-url) (commit commit)
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu build bootloader)
  #:use-module (guix build utils)
  #:use-module (guix utils)
  #:use-module (ice-9 binary-ports)
  #:use-module (ice-9 format)
  #:use-module (rnrs io ports)
  #:use-module (rnrs io simple)
  #:export (write-file-on-device
            install-efi-loader))


;;;
;;; Writing utils.
;;;

(define (write-file-on-device file size device offset)
  "Write SIZE bytes from FILE to DEVICE starting at OFFSET."
  (call-with-input-file file
    (lambda (input)
      (let ((bv (get-bytevector-n input size)))
        (call-with-port
         ;; Do not use "call-with-output-file" that would truncate the file.
         (open-file-output-port device
                                (file-options no-truncate no-fail)
                                (buffer-mode block)
                                ;; Use the binary-friendly ISO-8859-1
                                ;; encoding.
                                (make-transcoder (latin-1-codec)))
         (lambda (output)
           (seek output offset SEEK_SET)
           (put-bytevector output bv)))))))


;;;
;;; EFI bootloader.
;;;

(define* (install-efi grub grub-config esp #:key targets)
  "Write a self-contained GRUB EFI loader to the mounted ESP using
GRUB-CONFIG.

If TARGETS is set, use its car as the GRUB image format and its cdr as
the output filename.  Otherwise, use defaults for the host platform."
  (let* ((system %host-type)
         ;; Hard code the output location to a well-known path recognized by
         ;; compliant firmware. See "3.5.1.1 Removable Media Boot Behaviour":
         ;; http://www.uefi.org/sites/default/files/resources/UEFI%20Spec%202_6.pdf
         (grub-mkstandalone (string-append grub "/bin/grub-mkstandalone"))
         (efi-directory (string-append esp "/EFI/BOOT"))
         ;; Map grub target names to boot file names.
         (efi-targets (or targets
                          (cond ((string-prefix? "x86_64" system)
                                 '("x86_64-efi" . "BOOTX64.EFI"))
                                ((string-prefix? "i686" system)
                                 '("i386-efi" . "BOOTIA32.EFI"))
                                ((string-prefix? "armhf" system)
                                 '("arm-efi" . "BOOTARM.EFI"))
                                ((string-prefix? "aarch64" system)
                                 '("arm64-efi" . "BOOTAA64.EFI"))))))
    ;; grub-mkstandalone requires a TMPDIR to prepare the firmware image.
    (setenv "TMPDIR" esp)

    (mkdir-p efi-directory)
    (invoke grub-mkstandalone "-O" (car efi-targets)
            "-o" (string-append efi-directory "/"
                                (cdr efi-targets))
            ;; Graft the configuration file onto the image.
            (string-append "boot/grub/grub.cfg=" grub-config))))

(define* (install-efi-loader grub-efi esp #:key targets)
  "Install in ESP directory the given GRUB-EFI bootloader.  Configure it to
load the Grub bootloader located in the 'Guix_image' root partition.

If TARGETS is set, use its car as the GRUB image format and its cdr as
the output filename.  Otherwise, use defaults for the host platform."
  (let ((grub-config "grub.cfg"))
    (call-with-output-file grub-config
      (lambda (port)
        ;; Create a tiny configuration file telling the embedded grub where to
        ;; load the real thing.  XXX This is quite fragile, and can prevent
        ;; the image from booting when there's more than one volume with this
        ;; label present.  Reproducible almost-UUIDs could reduce the risk
        ;; (not eliminate it).
        (format port
                "insmod part_msdos~@
               insmod part_gpt~@
               search --set=root --label Guix_image~@
               configfile /boot/grub/grub.cfg~%")))
    (install-efi grub-efi grub-config esp #:targets targets)
    (delete-file grub-config)))

n extensive ;; amount of time to compile, especially with bootcheck functionality ;; enabled. To ensure that we do not monopolize the CI & build servers, ;; please make sure that your changes are justified. (define-public mercury (package (inherit mercury-minimal) (name "mercury") (version "20.06.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/Mercury-Language/mercury") (commit (string-append "version-" (string-join (string-split version #\.) "_"))))) (file-name (git-file-name name version)) (sha256 (base32 "1b6rmdinw8mj6n9sc7c75kkf42gd2k254rf51x4snlrqckxj7aaz")))) (arguments (substitute-keyword-arguments (package-arguments mercury-minimal) ;; TODO: Find a way to bypass all static linkages. ((#:configure-flags flags ''()) `(list "")) ((#:tests? _) #f) ; FIXME: Many test-cases failing. ((#:phases phases) `(modify-phases ,phases (replace 'patch-paths (lambda _ (substitute* (list "prepare.sh" "Makefile" "Mmakefile" "scripts/mercury_update_interface.in" "scripts/mercury_config.in" "scripts/mmake.in" "scripts/Mmake.vars.in" "scripts/mdb.in" "scripts/rs6000_hack" "scripts/fullarch" "scripts/mmc.in" "scripts/mprof.in" "scripts/gud.el" "scripts/ml.in" "scripts/canonical_grade.in" "scripts/mdprof.in" "scripts/vpath_find" "scripts/mkfifo_using_mknod.in" "scripts/prepare_install_dir.in" "scripts/mprof_merge_runs" "scripts/mtc" "scripts/mgnuc.in" "scripts/c2init.in" "tools/bootcheck" "boehm_gc/configure.ac" "boehm_gc/Makefile.direct") (("/bin/sh") (which "sh")) (("/bin/pwd") (which "pwd")) (("/bin/rm") (which "rm")) (("boehm_gc/.git") "boehm_gc")))) (replace 'bootstrap (lambda _ (invoke "./prepare.sh"))))))) ;; TODO: Uncomment phase when tests are enabled. ;; (replace 'check ;; (lambda _ ;; (invoke "./tools/bootcheck") ;; #t)) ;; ;; TODO: The mercury configuration system determines ;; grade support by looking for available toolchains. ;; Eventually we need to add inputs for Java, Erlang, ;; C#, etc. in order to enable these extra grades. (native-inputs (modify-inputs (package-native-inputs mercury-minimal) (prepend mercury-minimal autoconf automake))) (synopsis "Pure logic programming language")))