;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 John Darrington ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages marst) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (gnu packages compression) #:use-module (guix build-system gnu)) (define-public marst (package (name "marst") (version "2.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/" name "/" name "-" version ".tar.gz")) (sha256 (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/marst/") (synopsis "Algol-to-C translator") (description "GNU MARST is an Algol-to-C translator. The package consists of the translator itself, a library that contains the necessary Algol 60 procedures, and a converter that converts existing Algol 60 programs from other representations to the MARST representation.") (license gpl3+)))
AgeCommit message (Expand)Author
2022-02-14publish: Do not sign the URL/Compression/FileSize narinfo fields....Ludovic Courtès
2022-01-19tests: Adjust to gzip as the default log compression....Ludovic Courtès
2021-05-16publish: Add '--negative-ttl'....Ludovic Courtès
2021-03-31tests: Make 'publish' test umask-insensitive....Cees de Groot
2021-01-13publish: Add support for zstd compression....Ludovic Courtès
2020-11-08publish: Create files in the cache as #o644....Ludovic Courtès
2020-11-04publish: Do not path the empty string to 'query-path-info'....Ludovic Courtès
2020-10-28publish: Add '--cache-bypass-threshold'....Ludovic Courtès
2020-10-27publish: Provide server's signing key....Amar Singh
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-01-16publish: Export 'signed-string'....Ludovic Courtès