;;; GNU Guix --- Functional package management for GNU ;;; Copyright 2016 John Darrington ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages marst) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (gnu packages compression) #:use-module (guix build-system gnu)) (define-public marst (package (name "marst") (version "2.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/" name "/" name "-" version ".tar.gz")) (sha256 (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/marst/") (synopsis "Algol-to-C translator") (description "GNU MARST is an Algol-to-C translator. The package consists of the translator itself, a library that contains the necessary Algol 60 procedures, and a converter that converts existing Algol 60 programs from other representations to the MARST representation.") (license gpl3+)))
AgeCommit message (Expand)Author
2021-12-17gnu: boost-sync: Update to 1.55-1-e690de2d....Aleksandr Vityazev
2021-12-15gnu: boost-signals2: Update hash to matched moved tag....Aleksandr Vityazev
2021-12-13gnu: Simplify package inputs....Ludovic Courtès
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-11gnu: boost: Update to 1.77.0....Maxim Cournoyer
2021-11-08gnu: packages: Remove last year's deprecations....Tobias Geerinckx-Rice
2021-07-24gnu: Use 'search-input-file' when looking for executables....Ludovic Courtès
2021-07-24gnu: Use 'search-input-directory' when looking for C/C++ library headers....Ludovic Courtès
2021-06-19Merge branch 'master' into core-updates...Marius Bakke
2021-06-14gnu: Add boost-for-irods....Ricardo Wurmus
2021-05-22gnu: boost: Update to 1.76.0....Marius Bakke
2021-05-15Merge branch 'master' into core-updatesLudovic Courtès
2021-05-11gnu: boost: Migrate uri from bintray....Greg Hogan