;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2020 Martin Becze ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages loko) #:use-module (guix packages) #:use-module (guix gexp) #:use-module (guix git-download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages package-management) #:use-module (gnu packages guile) #:use-module (gnu packages guile-xyz) #:use-module (gnu packages chez)) (define-public loko-scheme (package (name "loko-scheme") (version "0.12.0") (source (origin (method git-fetch) (uri (git-reference (url "https://gitlab.com/weinholt/loko") (commit (string-append "v" version)))) (sha256 (base32 "12xp82z91qkp9q8lfp46s4sda8qgs472jic3js1kbykn4jzy7399")) (file-name (git-file-name name version)))) (build-system gnu-build-system) (arguments (list ;; r7rs tests are a work in progress as of 0.7.0. #:tests? #f #:strip-binaries? #f #:make-flags #~(list (string-append "PREFIX=" #$output)) #:phases #~(modify-phases %standard-phases (delete 'configure) (add-before 'build 'akku-fixes (lambda _ (delete-file "Akku.lock") (substitute* "Akku.manifest" (("\\(depends.*") "(depends)")) (invoke "akku" "install") (let ((dest "./.akku/lib/") (source "/share/guile/site/3.0/")) (for-each (lambda (name prefix) ;; Symlink the scheme libraries so that Akku can find them (symlink (string-append prefix source name) (string-append dest name))) '("struct" "laesare" "pfds" "machine-code") (list #$(this-package-native-input "guile-struct-pack") #$(this-package-native-input "guile-laesare") #$(this-package-native-input "guile-pfds") #$(this-package-native-input "guile-machine-code")))) (substitute* ".akku/env" (("/bin/sh") (which "sh"))) #t))))) (native-inputs (list akku chez-scheme guile-struct-pack guile-laesare guile-pfds guile-machine-code)) (home-page "https://scheme.fail") (synopsis "Implementation of the algorithmic language Scheme") (description "Loko Scheme is intended to be a platform for application and operating system development. It is written purely in Scheme and some assembler (i.e. no C code at the bottom). Both the R6RS and the R7RS standards are supported.") (license license:agpl3+))) 3 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libbsd)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages))

(define-public libbsd
  (package
    (name "libbsd")
    (version "0.8.3")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://libbsd.freedesktop.org/releases/"
                                  "libbsd-" version ".tar.xz"))
              (sha256
               (base32
                "1a1l7afchlvvj2zfi7ajcg26bbkh5i98y2v5h9j5p1px9m7n6jwk"))))
    (build-system gnu-build-system)
    (synopsis "Utility functions from BSD systems")
    (description "This library provides useful functions commonly found on BSD
systems, and lacking on others like GNU systems, thus making it easier to port
projects with strong BSD origins, without needing to embed the same code over
and over again on each project.")
    (home-page "https://libbsd.freedesktop.org/wiki/")
    ;; This package is a collection of third-party functions that were
    ;; originally released under various non-copyleft licenses.
    (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain
                   (non-copyleft "file://COPYING"
                                 "See COPYING in the distribution.")))))