;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages lightning) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses)) (define-public lightning (package (name "lightning") (version "2.0.5") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/lightning/lightning-" version ".tar.gz")) (sha256 (base32 "0jm9a8ddxc1v9hyzyv4ybg37fjac2yjqv1hkd262wxzqms36mdk5")))) (build-system gnu-build-system) (synopsis "Library for generating assembly code at runtime") (description "GNU Lightning is a library that generates assembly language code at run-time. Thus, it is useful in creating Just-In-Time compilers. It abstracts over the target CPU by exposing a standardized RISC instruction set to the clients.") (home-page "http://www.gnu.org/software/lightning/") (license gpl3+))) alue='grep'>log msg
AgeCommit message (Expand)Author
2019-04-22gnu: parallel: Update to 20190422....Tobias Geerinckx-Rice
2019-04-16gnu: slurm: Configure with a "standard" syslogdir....Ludovic Courtès
2019-03-22gnu: parallel: Update to 20190322....Tobias Geerinckx-Rice
2019-02-24gnu: parallel: Update to 20190222....Tobias Geerinckx-Rice
2019-02-12gnu: parallel: Update to 20190122....Tobias Geerinckx-Rice
2018-12-24gnu: parallel: Update to 20181222....Rutger Helling
2018-11-28gnu: parallel: Update to 20181122....Efraim Flashner
2018-10-27gnu: parallel: Update to 20181022....Tobias Geerinckx-Rice
2018-09-24gnu: parallel: Update to 20180922....Tobias Geerinckx-Rice
2018-08-24gnu: parallel: Update to 20180822....Ludovic Courtès
2018-07-30gnu: parallel: Update to 20180722....Efraim Flashner
2018-06-22gnu: parallel: Remove 'bash' input....Clément Lassieur
2018-06-22gnu: parallel: Wrap program instead of substituting 'ps' and 'perl'....Clément Lassieur
2018-06-21gnu: parallel: Update to 20180622....Clément Lassieur
2018-05-23gnu: parallel: Update to 20180522....Tobias Geerinckx-Rice
2018-04-25gnu: parallel: Update to 20180422....Rutger Helling
2018-03-23gnu: parallel: Update to 20180322....Tobias Geerinckx-Rice