;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 John J. Foerch ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages lighting) #:use-module (guix build-system gnu) #:use-module (guix gexp) #:use-module (guix git-download) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (gnu packages) #:use-module (gnu packages autotools) #:use-module (gnu packages bison) #:use-module (gnu packages check) #:use-module (gnu packages compression) #:use-module (gnu packages gnunet) #:use-module (gnu packages flex) #:use-module (gnu packages libftdi) #:use-module (gnu packages libusb) #:use-module (gnu packages linux) #:use-module (gnu packages pkg-config) #:use-module (gnu packages protobuf)) (define-public ola (package (name "ola") (version "0.10.8") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/OpenLightingProject/ola") (commit version))) (sha256 (base32 "17dwmjdw87hv314gv5b1rmh5jglz8a0rzw7wj26xn74xw2jvxa6l")) (file-name (git-file-name name version)))) (build-system gnu-build-system) (native-inputs (list bison cppunit flex pkg-config ;; For git repository bootstrapping. autoconf automake libtool)) (inputs (list libftdi libmicrohttpd libusb `(,util-linux "lib") zlib)) (propagated-inputs (list protobuf)) ; for pkg-config --libs libola (arguments (list ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing ;; build to fail on low memory systems. We disable that with the ;; following configure flags. #:configure-flags #~(list "CXXFLAGS=-ftrack-macro-expansion=0"))) (synopsis "Framework for controlling entertainment lighting equipment") (description "The Open Lighting Architecture is a framework for lighting control information. It supports a range of protocols and over a dozen USB devices. It can run as a standalone service, which is useful for converting signals between protocols, or alternatively using the OLA API, it can be used as the backend for lighting control software. OLA runs on many different platforms including ARM, which makes it a perfect fit for low cost Ethernet to DMX gateways.") (home-page "https://www.openlighting.org/ola") (license license:lgpl2.1+))) ='dt' onchange='this.form.submit();'>
authorng0 <ng0@n0.is>2018-01-14 17:23:00 +0000
committerLudovic Courtès <ludo@gnu.org>2018-01-16 16:00:20 +0100
commitb83fc85f9f40d9a5dff5b0d3ef38c1b93bd4c7e3 (patch)
tree2c5474f44498bb0ad809a30df96b723857bb9702 /configure.ac
parent889b4af7d89a8ce0f05e210b6bd2212f787659a4 (diff)
downloadguix-b83fc85f9f40d9a5dff5b0d3ef38c1b93bd4c7e3.tar.gz
guix-b83fc85f9f40d9a5dff5b0d3ef38c1b93bd4c7e3.zip
etc: Add completions for fish.
* etc/completion/fish/guix.fish: New file. * Makefile.am: Register the file. * configure.ac: Add the fish vendor-completions directory. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53efa4a684..1e39122483 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,13 @@ AC_ARG_WITH([zsh-completion-dir],
[zshcompletiondir='${datadir}/zsh/site-functions'])
AC_SUBST([zshcompletiondir])
+AC_ARG_WITH([fish-completion-dir],
+ AC_HELP_STRING([--with-fish-completion-dir=DIR],
+ [name of the Fish completion directory]),
+ [fishcompletiondir="$withval"],
+ [fishcompletiondir='${datadir}/fish/vendor_completions.d'])
+AC_SUBST([fishcompletiondir])
+
dnl Better be verbose.
AC_MSG_CHECKING([for the store directory])
AC_MSG_RESULT([$storedir])