;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libpng) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:)) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public libpng (package (name "libpng") (version "1.5.17") (source (origin (method url-fetch) ;; Note: upstream removes older tarballs. (uri (list (string-append "mirror://sourceforge/libpng/libpng15/" version "/libpng-" version ".tar.xz") (string-append "ftp://ftp.simplesystems.org/pub/libpng/png/src" "/libpng15/libpng-" version ".tar.xz"))) (sha256 (base32 "19wj293r4plbfgb43yhrc2qx8bsch9gbazazfqrj9haa7lsk29jp")))) (build-system gnu-build-system) ;; libpng.la says "-lz", so propagate it. (propagated-inputs `(("zlib" ,zlib))) (synopsis "Library for handling PNG files") (description "Libpng is the official PNG (Portable Network Graphics) reference library. It supports almost all PNG features and is extensible.") (license license:zlib) (home-page "http://www.libpng.org/pub/png/libpng.html"))) 2b8a3d34b0324319cd36e6c0a2'>root/gnu/packages/mp3.scm
AgeCommit message (Expand)Author
2020-03-13gnu: taglib: Use HTTPS home page....Tobias Geerinckx-Rice
2020-01-03gnu: eyed3: Update to 0.8.12....Tobias Geerinckx-Rice
2019-12-28gnu: Add python-pyacoustid....Ricardo Wurmus
2019-12-28gnu: Add python-audioread....Ricardo Wurmus
2019-11-11gnu: eyed3: Update to 0.8.11....Tobias Geerinckx-Rice
2019-10-27gnu: mpg123: Update to 1.25.13....Tobias Geerinckx-Rice
2019-10-13gnu: id3lib: Apply patch for UTF16 writing bug....Pierre Langlois
2019-11-22gnu: man-pages: Update to 5.04....Tobias Geerinckx-Rice
2019-10-28gnu: scdoc: Set PREFIX instead of patching Makefile....Brendan Tildesley
2019-10-26gnu: man-db: Update to 2.9.0....Tobias Geerinckx-Rice
2019-10-16gnu: man-pages: Update to 5.03....Tobias Geerinckx-Rice
2019-08-22Merge branch 'master' into core-updatesMark H Weaver
2019-08-21gnu: help2man: Update to 1.47.11....Tobias Geerinckx-Rice
2019-08-13Merge branch 'master' into core-updatesMarius Bakke
2019-08-03gnu: man-pages: Update to 5.02....Tobias Geerinckx-Rice