;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2018 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libphidget) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages libusb)) (define-public libphidget (package (name "libphidget") (version "2.1.8.20180607") (source (origin (method url-fetch) (uri (string-append "https://www.phidgets.com/downloads/phidget21/libraries/" "linux/libphidget/libphidget_" version ".tar.gz")) (sha256 (base32 "1mdw8k13yy5dq3r41v9w5yijdk87alzix0qagslc2mxh1pf17npn")))) (build-system gnu-build-system) (inputs `(("libusb" ,libusb))) (outputs '("out" "debug")) (home-page "https://www.phidgets.com/") (license lgpl3+) (synopsis "C library to manipulate Phidgets") (description synopsis))) 4cac9d0fe628b82ffb1d127ad3e42f'/>
AgeCommit message (Expand)Author
2024-02-19gnu: go-golang-org-x-net-html: Add missing input....Troy Figiel
2024-02-13gnu: go-golang-org-x-crypto: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-image: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-tools: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-github-com-yuin-goldmark: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-text: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-time: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-term: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-sync: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang.org-x-sync-errgroup: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-xerrors: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-mod: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-exp: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-sys: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-golang-org-x-net: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: Add (gnu packages golang-build) module....Sharlatan Hellseher