;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2018 Efraim Flashner ;;; Copyright © 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libphidget) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages libusb)) (define-public libphidget (package (name "libphidget") (version "2.1.9.20190409") (source (origin (method url-fetch) (uri (string-append "https://www.phidgets.com/downloads/phidget21/libraries/" "linux/libphidget/libphidget_" version ".tar.gz")) (sha256 (base32 "07w54dmr75vq2imngfy66nk1sxlvkzhl2p6g362q0a02f099jy0f")))) (build-system gnu-build-system) (inputs (list libusb)) (outputs '("out" "debug")) (home-page "https://www.phidgets.com/") (license lgpl3+) (synopsis "C library to manipulate Phidgets") (description synopsis))) thor'>author
AgeCommit message (Expand)Author
2020-10-04gnu: hplip: Update to 3.20.9 [security fixes]....Tobias Geerinckx-Rice
2020-10-01gnu: escpr: Mark up description....Tobias Geerinckx-Rice
2020-09-29gnu: escpr: Update to 1.7.7....Tobias Geerinckx-Rice
2020-09-29gnu: escpr: Install PPDs where CUPS can find them....Tobias Geerinckx-Rice
2020-07-04gnu: hplip: Update source hash....Tobias Geerinckx-Rice
2020-06-17gnu: foo2zjs: Update to 20200610....Tobias Geerinckx-Rice
2020-06-17gnu: hplip: Update to 3.20.6....Tobias Geerinckx-Rice
2020-06-06Merge branch 'master' into stagingMarius Bakke
2020-06-02gnu: hplip: Update to 3.20.5....Tobias Geerinckx-Rice
2020-05-26Merge branch 'master' into stagingMarius Bakke
2020-05-26gnu: CUPS: Update to 2.3.3....Marius Bakke
2020-05-26gnu: cups-filters: Update to 1.27.4....Marius Bakke
2020-05-18gnu: CUPS: Inherit replacement from cups-minimal....Marius Bakke
2020-05-17gnu: cups: Update to 2.3.3 [fixes CVE-2020-3898 & CVE-2019-8842]....Tobias Geerinckx-Rice
2020-05-04gnu: hplip: Fix build with Python 3.8....Marius Bakke
2020-04-30Merge branch 'master' into core-updates...Marius Bakke
2020-04-29gnu: foo2zjs: Update to 20200426....Tobias Geerinckx-Rice