;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2018 Efraim Flashner ;;; Copyright © 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libphidget) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages libusb)) (define-public libphidget (package (name "libphidget") (version "2.1.9.20190409") (source (origin (method url-fetch) (uri (string-append "https://www.phidgets.com/downloads/phidget21/libraries/" "linux/libphidget/libphidget_" version ".tar.gz")) (sha256 (base32 "07w54dmr75vq2imngfy66nk1sxlvkzhl2p6g362q0a02f099jy0f")))) (build-system gnu-build-system) (inputs (list libusb)) (outputs '("out" "debug")) (home-page "https://www.phidgets.com/") (license lgpl3+) (synopsis "C library to manipulate Phidgets") (description synopsis)))
AgeCommit message (Expand)Author
2022-01-29gnu: choqok: Don't depend on QtWebKit.Leo Famulari
2021-12-13gnu: Further simplify package inputs.Ludovic Courtès
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-06-14gnu: Rename qtbase to qtbase-5.Maxim Cournoyer
2020-12-12gnu: KDE: Fix old cgit home-pages.Hartmut Goebel
2020-11-01gnu: konversation: Update to 1.7.7.Tobias Geerinckx-Rice
2020-10-05gnu: konversation: Update to 1.7.6.Tobias Geerinckx-Rice
2020-09-30gnu: Fix package references.Efraim Flashner
2020-06-06gnu: KDE: Update to 20.04.1.Marius Bakke