;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages libidn)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages libunistring)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public libidn
  (package
   (name "libidn")
   (version "1.41")
   (source (origin
            (method url-fetch)
            (uri (string-append "mirror://gnu/libidn/libidn-" version
                                ".tar.gz"))
            (sha256
             (base32
              "0ic9zlqqppwaqr3i0r8lb8f47rrazzc8d5pfgg8vs6mqciip0kc8"))))
   (build-system gnu-build-system)
   ;; FIXME: No Java and C# libraries are currently built.
   (arguments
    `(#:configure-flags '("--disable-static")))
   (synopsis "Internationalized string processing library")
   (description
     "libidn is a library implementing of the Stringprep, Punycode and IDNA
specifications.  These are used to encode and decode internationalized domain
names according to the IDNA2003 specifications.  It includes native C, C# and
Java libraries.")
   ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
   ;; the command line tool is gpl3+.
   (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
   (home-page "https://www.gnu.org/software/libidn/")))

(define-public libidn2
  (package
    (name "libidn2")
    (version "2.3.4")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/libidn/" name "-" version
                                  ".tar.gz"))
              (sha256
               (base32
                "0pxlvf37j9ivg2wp56q1xvx7g6y9cfmpd87mskwd2lg0nirbmjlk"))))
    (inputs
     (list libunistring))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags '("--disable-static")))
    (synopsis "Internationalized domain name library for IDNA2008")
    (description "Libidn2 is an internationalized domain library implementing
the IDNA2008 specifications.   Libidn2 is believed to be a complete IDNA2008
implementation, but has yet to be as extensively used as the original Libidn
library.")
    (home-page "https://www.gnu.org/software/libidn/#libidn2")
    (properties '((ftp-directory . "/gnu/libidn")))
    ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
    ;; GPL2+ or LGPL3+.
    (license (list gpl2+ gpl3+ lgpl3+))))
57'>gnu: php: Update to 7.4.14.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php): Update to 7.4.14.
</span></span></td><td>Julien Lepiller</td></tr>
<tr><td><span title='2020-11-26 04:22:51 +0100'>2020-11-26</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=824a9f1060111d9ab2317b1453360e39eda8201a'>gnu: php: Update to 7.4.13.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php): Update to 7.4.13.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>
<tr><td><span title='2020-11-05 03:46:09 +0100'>2020-11-05</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=08d8e76678c7cedb65f2faded6310f140f31164e'>gnu: php: Move a test disablement.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php)[arguments]: Disable bug73837.phpt under a
more appropriate comment section.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>
<tr><td><span title='2020-10-30 09:51:38 +0100'>2020-10-30</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=697d2e037bc999760b85b7904079679e0ccc1e62'>gnu: php: Update to 7.4.12 [security fixes].</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php): Update to 7.4.12.
[arguments]: Disable two more failing tests.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>
<tr><td><span title='2020-10-01 00:13:41 +0200'>2020-10-01</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=9e93bffb58b3992bdcf5a0a2dc9f5bc9cd1cffd5'>gnu: php: Update to 7.4.11.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php): Update to 7.4.11.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>
<tr><td><span title='2020-09-21 15:24:07 +0200'>2020-09-21</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=f23e439f9f89b8dbcc5bf76135842a1e49f8526a'>gnu: php: Disable unreliable test.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php)[arguments]: Delete bug73837.phpt.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>
<tr><td><span title='2020-09-04 11:01:04 +0200'>2020-09-04</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=eb3328004ebf69d258b1afc46b5cab010c1a4a26'>gnu: php: Update to 7.4.10.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php): Update to 7.4.10.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>
<tr><td><span title='2020-08-13 16:09:40 +0200'>2020-08-13</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=d1c37def6e22fa4e171a96f97347220cf2ed5aa9'>gnu: php: Update to 7.4.9.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php): Update to 7.4.9.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>
<tr><td><span title='2020-07-11 23:24:29 +0200'>2020-07-11</span></td><td><a href='/guix/commit/gnu/packages/php.scm?id=7ed0eeb0113f4fe7c56ca649c05b08df8ecd66fb'>gnu: php: Update to 7.4.8.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/php.scm (php): Update to 7.4.8.
</span></span></td><td>Tobias Geerinckx-Rice</td></tr>