;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis ;;; Copyright © 2018 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libftdi) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix packages) #:use-module (gnu packages) #:use-module (gnu packages libusb) #:use-module (guix build-system cmake)) (define-public libftdi (package (name "libftdi") (version "1.4") (source (origin (method url-fetch) (uri (string-append "http://www.intra2net.com/en/developer/libftdi/download/libftdi1-" version ".tar.bz2")) (sha256 (base32 "0x0vncf6i92slgrn0h7ghkskqbglbs534220qa84d0qg114zndpc")))) (build-system cmake-build-system) (propagated-inputs (list libusb)) ; required by libftdi1.pc (home-page "https://www.intra2net.com/en/developer/libftdi/") (synopsis "FTDI USB driver with bitbang mode") (description "libFTDI is a library to talk to FTDI chips: FT232BM, FT245BM, FT2232C, FT2232D, FT245R and FT232H including the popular bitbangmode.") (license lgpl2.1))) 'search' size='10' name='q' value=''/>
AgeCommit message (Expand)Author
2023-08-06gnu: libxmlb: Update to 0.3.12.Tobias Geerinckx-Rice
2023-08-13gnu: freexl: Update to 2.0.0.Felix Gruber
2023-07-09gnu: libxml2: Download using mirror uri.Efraim Flashner
2023-07-09gnu: libxslt: Download using mirror uri.Efraim Flashner
2023-06-01gnu: html-xml-utils: Update to 8.6.Greg Hogan
2023-04-21gnu: opensp: Fix build.Maxim Cournoyer
2023-04-21gnu: opensp: Remove patch-docbook-xml phase.Maxim Cournoyer
2023-03-10gnu: libxslt: Really allow cross-compilation.Ludovic Courtès
2023-03-09gnu: libxslt: Allow cross-compilation.Ludovic Courtès
2023-03-02Merge remote-tracking branch 'savannah/master' into core-updatesChristopher Baines
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2023-02-18gnu: xmlsec: Update to 1.2.37.Maxim Cournoyer