;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Joshua S. Grant ;;; Copyright © 2015 Mark H Weaver ;;; Copyright © 2017, 2018 Efraim Flashner ;;; Copyright © 2020 Marius Bakke ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libffcall) #:use-module ((guix licenses) #:prefix l:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public libffcall (package (name "libffcall") (version "2.2") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/libffcall/libffcall-" version ".tar.gz")) (sha256 (base32 "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb")))) (build-system gnu-build-system) (arguments '(#:parallel-build? #f #:configure-flags '("--disable-static"))) (synopsis "Foreign function calls from interpreters") (description "GNU Libffcall is a collection of libraries that can be used to build foreign function call interfaces in embedded interpreters.") (home-page "https://www.gnu.org/software/libffcall/") (license l:gpl2+))) lass='txt' type='search' size='10' name='q' value=''/>
AgeCommit message (Expand)Author
2023-02-25gnu: gparted: Update to 1.5.0....Michael Rohleder
2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice
2023-01-22gnu: ndctl: Update to 75....Tobias Geerinckx-Rice
2023-01-22gnu: ddrescue: Update to 1.27....Tobias Geerinckx-Rice
2022-12-05gnu: gparted: Move lvm2 to inputs....Efraim Flashner
2022-11-27gnu: libblockdev: Update to 2.28....Tobias Geerinckx-Rice
2022-11-27gnu: lf: Fix build....Tobias Geerinckx-Rice
2022-11-22gnu: Add fff....paladhammika
2022-11-10gnu: parted: Add a debug output....Mathieu Othacehe
2022-10-31gnu: Add wipe....Denis 'GNUtoo' Carikli
2022-09-04gnu: gparted: Update to 1.4.0....Tobias Geerinckx-Rice
2022-08-27gnu: scons: Move to (gnu packages build-tools)....Marius Bakke
2022-07-24gnu: duc: Run tests....Tobias Geerinckx-Rice
2022-07-24gnu: duc: Update to 1.4.5....Tobias Geerinckx-Rice
2022-07-24gnu: qdirstat: Update to 1.8.1....Tobias Geerinckx-Rice