;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Joshua S. Grant ;;; Copyright © 2015 Mark H Weaver ;;; Copyright © 2017, 2018 Efraim Flashner ;;; Copyright © 2020 Marius Bakke ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libffcall) #:use-module ((guix licenses) #:prefix l:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public libffcall (package (name "libffcall") (version "2.2") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/libffcall/libffcall-" version ".tar.gz")) (sha256 (base32 "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb")))) (build-system gnu-build-system) (arguments '(#:parallel-build? #f #:configure-flags '("--disable-static"))) (synopsis "Foreign function calls from interpreters") (description "GNU Libffcall is a collection of libraries that can be used to build foreign function call interfaces in embedded interpreters.") (home-page "https://www.gnu.org/software/libffcall/") (license l:gpl2+))) earch'/>
path: root/gnu/tests
1487d4ca07ec'>services: dhcp-client-service-type: Support DDNS....
AgeCommit message (Expand)Author
2020-10-01services: hurd-vm: Resurrect system-test by using raw disk-image....Jan (janneke) Nieuwenhuizen
2020-09-30system: image: Add image-type support....Mathieu Othacehe
2020-09-29services: hurd-vm: Add system test....Ludovic Courtès
2020-09-10tests: nfs: Improve "nfs-root-fs"....Danny Milosavljevic
2020-09-10tests: install: Fix gui-installed-desktop-os-encrypted test....Mathieu Othacehe
2020-09-07tests: nfs: Improve "nfs-root-fs"....Danny Milosavljevic
2020-09-07tests: Add "nfs-root-fs" system test....Stefan
Lilah Tascheter
2023-09-22services: nftables: Add 'configuration' action....Marius Bakke
2023-09-17services: dhcp-client: Fix name of the provision accessor....Ludovic Courtès
2023-09-17services: dhcp-client-configuration: Allow provision override....Alexey Abramov
2023-09-08services: Open vSwitch: Depend on 'user-processes' target....Marius Bakke