;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Federico Beffa ;;; Copyright © 2015 Ricardo Wurmus ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libedit) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages ncurses)) (define-public libedit (package (name "libedit") (version "20150325-3.1") (source (origin (method url-fetch) (uri (string-append "http://thrysoee.dk/editline" "/" name "-" version ".tar.gz")) (sha256 (base32 "1if8zi9h52m80ck796an28rrqfljk2n8cn25m3fl0prwz155x2n8")))) (build-system gnu-build-system) (arguments `(#:configure-flags (list "--enable-widec"))) (inputs `(("ncurses" ,ncurses))) (home-page "http://thrysoee.dk/editline/") (synopsis "NetBSD Editline library") (description "This is an autotool- and libtoolized port of the NetBSD Editline library (libedit). This Berkeley-style licensed command line editor library provides generic line editing, history, and tokenization functions, similar to those found in GNU Readline.") (license bsd-3))) ;;; libedit.scm ends here alue=''/>
AgeCommit message (Expand)Author
2016-05-19Update name for Kei Kebreau....Kei Kebreau
2016-04-28gnu: fltk: Fix undefined symbol `Fl_XFont_On_Demand::value'....宋文武
2016-04-18gnu: fltk: Add Xft support....Kei Yamashita
2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost
2015-07-26gnu: ntk: Add missing license import....Ricardo Wurmus
2015-07-26gnu: Add NTK....Ricardo Wurmus
2015-05-19gnu: fltk: Use system zlib, libjpeg, and libpng....Eric Bavier
2015-05-05gnu: fltk: Fix undefined symbol errors for shared libraries....Eric Bavier
2015-04-15gnu: fltk: Add $libdir to the RUNPATH of binaries....宋文武
2015-04-15gnu: fltk: Update to 1.3.3....宋文武
2014-12-28gnu: Fix or update a number of 'home-page' fields....Ludovic Courtès
2014-10-26gnu: Some cleanup based on lint checkers....Eric Bavier
2014-04-07gnu: fltk: Build shared libraries...Eric Bavier
2014-03-31gnu: Remove unused lambda arguments and prefer separate phases over...Eric Bavier
2014-01-25gnu: fltk: New module...John Darrington