;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Federico Beffa ;;; Copyright © 2015 Ricardo Wurmus ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libedit) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages ncurses)) (define-public libedit (package (name "libedit") (version "20150325-3.1") (source (origin (method url-fetch) (uri (string-append "http://thrysoee.dk/editline" "/" name "-" version ".tar.gz")) (sha256 (base32 "1if8zi9h52m80ck796an28rrqfljk2n8cn25m3fl0prwz155x2n8")))) (build-system gnu-build-system) (arguments `(#:configure-flags (list "--enable-widec"))) (inputs `(("ncurses" ,ncurses))) (home-page "http://thrysoee.dk/editline/") (synopsis "NetBSD Editline library") (description "This is an autotool- and libtoolized port of the NetBSD Editline library (libedit). This Berkeley-style licensed command line editor library provides generic line editing, history, and tokenization functions, similar to those found in GNU Readline.") (license bsd-3))) ;;; libedit.scm ends here />
k
AgeCommit message (Expand)Author<
2018-03-03gnu: wv: Edit description....Tobias Geerinckx-Rice
2019-02-17gnu: openmpi: Add InfiniBand support....Ricardo Wurmus
2019-02-09gnu: openmpi: Upgrade to 4.0.0....Eric Bavier
2019-02-07gnu: openmpi: Add dependency on SLURM....Ludovic Courtès
2019-01-31gnu: hwloc: Update to 2.0.3....Marius Bakke
2019-01-31gnu: hwloc@1: Update to 1.11.12....Marius Bakke
2018-11-14gnu: Add python-mpi4py....Paul Garlick
2018-10-04gnu: hwloc: Update to 2.0.2....Tobias Geerinckx-Rice
2018-09-11mpi: Factorize openmpi setup build phase....Eric Bavier
2018-05-25gnu: openmpi: Add PSM2 (Intel OmniPath) support....Ludovic Courtès
2018-05-25gnu: openmpi: Reintroduce PSM (Intel TrueScale) support....Ludovic Courtès
2018-05-25gnu: openmpi: Update to 3.0.1....Ludovic Courtès
2018-04-10gnu: hwloc: Skip 'linux-libnuma' test....Ludovic Courtès
2018-03-26gnu: hwloc@1: Update to 1.11.10....Ludovic Courtès
2018-03-26gnu: hwloc@2: Update to 2.0.1....Ludovic Courtès
2018-03-26gnu: hwloc@1: Update to 1.11.9....Ludovic Courtès