;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Federico Beffa ;;; Copyright © 2015 Ricardo Wurmus ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libedit) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages ncurses)) (define-public libedit (package (name "libedit") (version "20150325-3.1") (source (origin (method url-fetch) (uri (string-append "http://thrysoee.dk/editline" "/" name "-" version ".tar.gz")) (sha256 (base32 "1if8zi9h52m80ck796an28rrqfljk2n8cn25m3fl0prwz155x2n8")))) (build-system gnu-build-system) (arguments `(#:configure-flags (list "--enable-widec"))) (inputs `(("ncurses" ,ncurses))) (home-page "http://thrysoee.dk/editline/") (synopsis "NetBSD Editline library") (description "This is an autotool- and libtoolized port of the NetBSD Editline library (libedit). This Berkeley-style licensed command line editor library provides generic line editing, history, and tokenization functions, similar to those found in GNU Readline.") (license bsd-3))) ;;; libedit.scm ends here /option>
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:16 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:16 +0100
commitdb82f64cf785474276283298ecb803a280b41091 (patch)
treedd0cc10f65bd5c30d9046d9715d172b668af228f /gnu/installer/timezone.scm
parent12e05563695044649154ba51eef8acddc72797fe (diff)
downloadguix-db82f64cf785474276283298ecb803a280b41091.tar.gz
guix-db82f64cf785474276283298ecb803a280b41091.zip
gnu: Add node-segfault-handler.
* gnu/packages/node-xyz.scm (node-segfault-handler): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/installer/timezone.scm')
0 files changed, 0 insertions, 0 deletions