;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libcanberra) #:use-module ((guix licenses) #:select (lgpl2.1+)) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages autotools) #:use-module (gnu packages gstreamer) #:use-module (gnu packages gtk) #:use-module (gnu packages linux) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xiph)) (define-public libcanberra (package (name "libcanberra") (version "0.30") (source (origin (method url-fetch) (uri (string-append "http://0pointer.de/lennart/projects/libcanberra/libcanberra-" version ".tar.xz")) (sha256 (base32 "0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2")))) (build-system gnu-build-system) (inputs ;; FIXME: Add optional inputs udev and pulse. `(("alsa-lib" ,alsa-lib) ("gstreamer" ,gstreamer) ("gtk+" ,gtk+) ("libtool" ,libtool) ("libvorbis" ,libvorbis))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "http://0pointer.de/lennart/projects/libcanberra/") (synopsis "Implementation of the XDG Sound Theme and Name Specifications") (description "Libcanberra is an implementation of the XDG Sound Theme and Name Specifications, for generating event sounds on free desktops, such as GNOME. It comes with several backends (ALSA, PulseAudio, OSS, GStreamer, null) and is designed to be portable.") (license lgpl2.1+))) cre.scm?id=d815728525f97373942072db48fcf497b02919fd'>pcre.scm
AgeCommit message (Expand)Author
2018-07-22gnu: pcre: Update to 8.42....Marius Bakke
2018-07-19gnu: pcre: Install static libraries to separate output....Marius Bakke
2018-02-28gnu: pcre2: Update to 10.31....Tobias Geerinckx-Rice
2018-01-19Merge branch 'master' into core-updatesMark H Weaver
2018-01-13gnu: pcre: Use HTTPS for home pages....Tobias Geerinckx-Rice
2017-10-01gnu: pcre: Update to 8.41....Efraim Flashner
2017-07-23Merge branch 'master' into core-updatesLeo Famulari
2017-07-20gnu: pcre: Update replacement to 8.41 [fixes CVE-2017-{7244,7245,7246}]....Leo Famulari
2017-07-03packages: Mark 'replacement' as an "innate" field....Ludovic Courtès
2017-05-24Merge branch 'master' into core-updatesRicardo Wurmus
2017-05-07gnu: pcre2: Fix build configuration for pcre2....Leo Famulari
2017-05-07gnu: pcre2: Fix CVE-2017-8786....Leo Famulari
2017-04-10gnu: pcre: Patch CVE-2017-7186....Ludovic Courtès
2017-04-10gnu: pcre2: Patch CVE-2017-7186....Ludovic Courtès
2017-03-09Merge branch 'master' into core-updatesLudovic Courtès
2017-03-07gnu: pcre2: Update to 10.23....Marius Bakke
2017-01-23gnu: pcre: Update to 8.40....Leo Famulari