;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Leo Famulari ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libbsd) #:use-module (guix build-system gnu) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages)) (define-public libbsd (package (name "libbsd") (version "0.8.7") (source (origin (method url-fetch) (uri (string-append "https://libbsd.freedesktop.org/releases/" "libbsd-" version ".tar.xz")) (sha256 (base32 "0c9bl49zs0xdddcwj5dh0lay9sxi2m1yi74848g8p87mb87g2j7m")))) (build-system gnu-build-system) (synopsis "Utility functions from BSD systems") (description "This library provides useful functions commonly found on BSD systems, and lacking on others like GNU systems, thus making it easier to port projects with strong BSD origins, without needing to embed the same code over and over again on each project.") (home-page "https://libbsd.freedesktop.org/wiki/") ;; This package is a collection of third-party functions that were ;; originally released under various non-copyleft licenses. (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain (non-copyleft "file://COPYING" "See COPYING in the distribution."))))) a82d438fe903038'>root/gnu/installer.scm
AgeCommit message (Expand)Author
2023-12-25gnu: Adjust to removing ed.scm and nano.scm...Efraim Flashner
2023-12-02gnu: Use ‘libc-utf8-locales-for-target’....Janneke Nieuwenhuizen
2022-12-05installer: Log provenance data....Ludovic Courtès
2022-11-15installer: Migrate to 'guile-gnutls'....Ludovic Courtès
2022-11-15installer: Report known-unsupported PCI devices....Ludovic Courtès
2022-11-15installer: Use 'current-guix' for extensions....Ludovic Courtès
2022-11-02installer: Skip the backtrace page on user abort....Mathieu Othacehe
2022-11-02installer: Add core dump support....Mathieu Othacehe
2022-08-08installer: Render the final configuration with (guix read-print)....Ludovic Courtès