;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Leo Famulari ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages libbsd) #:use-module (guix build-system gnu) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages)) (define-public libbsd (package (name "libbsd") (version "0.8.3") (source (origin (method url-fetch) (uri (string-append "https://libbsd.freedesktop.org/releases/" "libbsd-" version ".tar.xz")) (sha256 (base32 "1a1l7afchlvvj2zfi7ajcg26bbkh5i98y2v5h9j5p1px9m7n6jwk")))) (build-system gnu-build-system) (synopsis "Utility functions from BSD systems") (description "This library provides useful functions commonly found on BSD systems, and lacking on others like GNU systems, thus making it easier to port projects with strong BSD origins, without needing to embed the same code over and over again on each project.") (home-page "https://libbsd.freedesktop.org/wiki/") ;; This package is a collection of third-party functions that were ;; originally released under various non-copyleft licenses. (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain (non-copyleft "file://COPYING" "See COPYING in the distribution."))))) 43'>NEWS
ctory commit, and another test targeting the v1.2.0 commit. * doc/guix.texi (Specifying Channel Authorizations): Add a sentence.
AgeCommit message (Expand)Author
2020-11-22Update NEWS.Ludovic Courtès
2020-11-13Update NEWS.Ludovic Courtès
2020-11-09Update NEWS.Ludovic Courtès
2020-11-07Update NEWS.Mathieu Othacehe
2020-11-07Update NEWS.Ludovic Courtès
2020-11-05Update NEWS.Ludovic Courtès
2020-04-15Update NEWS.Ludovic Courtès
2020-04-12Update NEWS.Ludovic Courtès
2020-04-09Update NEWS.Ludovic Courtès
2019-05-17Update NEWS.Ludovic Courtès
2019-05-16Update NEWS.Ludovic Courtès
2019-05-01Update NEWS.Ludovic Courtès
2019-04-29Update NEWS.Ludovic Courtès
2019-04-28Update NEWS.Ludovic Courtès
Ludovic Courtès
2021-12-22tests: Move keys into ./tests/keys/ and add a third ed25519 key....The third key will be used in an upcoming commit. Rename public keys to .pub. * guix/tests/gnupg.scm (%ed25519-3-public-key-file): New variable. (%ed25519-3-secret-key-file): New variable. (%ed25519-2-public-key-file): Renamed from %ed25519bis-public-key-file. (%ed25519-2-secret-key-file): Renamed from %ed25519bis-secret-key-file. * tests/keys/ed25519-3.key: New file. * tests/keys/ed25519-3.sec: New file. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Attila Lendvai
2021-09-18channels: 'channel-news-entry-commit' correctly resolves annotated tags....Previously, 'channel-news-entry-commit' would return the tag ID rather than the commit ID when the news entry was referred to via an annotated tag. Reported by Xinglu Chen <public@yoctocell.xyz>. * guix/channels.scm (resolve-channel-news-entry-tag): Check whether the reference points to annotated tag; resolve it if it does. * tests/channels.scm ("channel-news, annotated tag"): New test. Ludovic Courtès