;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages less) #:use-module (guix licenses) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public less (package (name "less") (version "451") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/less/less-" version ".tar.gz")) (sha256 (base32 "0mszdd9m1dsbg59pav62swg9f87xmjpfspcw2jsazzksciy2is4z")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (home-page "https://www.gnu.org/software/less/") (synopsis "Paginator for terminals") (description "GNU less is a pager, a program that allows you to view large amounts of text in page-sized chunks. Unlike traditional pagers, it allows both backwards and forwards movement through the document. It also does not have to read the entire input file before starting, so it starts faster than most text editors.") (license gpl3+))) ; some files are under GPLv2+ option>
AgeCommit message (Expand)Author
2023-11-23gnu: Update ispell to 3.4.06.Arnaud DABY-SEESARAM
2023-07-09gnu: aspell-dict-nb: Correct to 0.50-2.Tobias Geerinckx-Rice
2023-03-02Merge remote-tracking branch 'savannah/master' into core-updatesChristopher Baines
2023-03-01gnu: aspell: fix cross-compile.Z572
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2023-02-23gnu: Add aspell-dict-bg.Yovan Naumovski
2023-01-30Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner
2023-01-04gnu: hunspell: Move hunspell and dictionaries to hunspell module.Brian Cully
2023-01-03gnu: Add aspell-dict-bn.Akib Azmain Turja
2022-12-14gnu: Add aspell-dict-nb.Simen Endsjø
2022-08-12gnu: aspell: Incorporate grafted changes.Marius Bakke
2022-08-10gnu: aspell: Fix CVE-2019-25051 with a graft.Marius Bakke
2022-08-09gnu: aspell: Patch CVE-2019-25051.Efraim Flashner
2022-05-01gnu: ispell: Update to 3.4.05.Tobias Geerinckx-Rice
2022-01-14gnu: aspell-dictionary: Try to find new releases.Efraim Flashner