;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages less) #:use-module (guix licenses) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public less (package (name "less") (version "481") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/less/less-" version ".tar.gz")) (sha256 (base32 "19fxj0h10y5bhr3a1xa7kqvnwl44db3sdypz8jxl1q79yln8z8rz")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (home-page "https://www.gnu.org/software/less/") (synopsis "Paginator for terminals") (description "GNU less is a pager, a program that allows you to view large amounts of text in page-sized chunks. Unlike traditional pagers, it allows both backwards and forwards movement through the document. It also does not have to read the entire input file before starting, so it starts faster than most text editors.") (license gpl3+))) ; some files are under GPLv2+ e='search' size='10' name='q' value=''/>
AgeCommit message (Expand)Author
2020-12-23etc: snippets: Add new build systems to package snippet....Morgan Smith
2020-12-04etc: snippets: Fix name extraction....Nicolas Goaziou
2020-12-04etc: snippets: Fix name extraction....Nicolas Goaziou
2020-11-25etc: snippets: Fix "gnu: Add ..." name when prefilling Common Lisp commits me......Pierre Neidhardt
2020-11-23etc: snippets: Prefill Common Lisp package names....Pierre Neidhardt
2020-11-23etc: snippets: Fix package name extraction....Pierre Neidhardt
2019-05-09Add (guix bzr-download)....Maxim Cournoyer
2019-03-26etc: Add "rename" snippet....Pierre Neidhardt
2019-03-08etc: snippets: Prefill package name....Ricardo Wurmus
2019-03-07etc: snippets: Prefill package name and version....Ricardo Wurmus