;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages less) #:use-module (guix licenses) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public less (package (name "less") (version "487") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/less/less-" version ".tar.gz")) (sha256 (base32 "01i7n6jaxwmww3pasy3hg38zc6x7jw0w05mqqvh6caqbrdaq9p7k")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (home-page "https://www.gnu.org/software/less/") (synopsis "Paginator for terminals") (description "GNU less is a pager, a program that allows you to view large amounts of text in page-sized chunks. Unlike traditional pagers, it allows both backwards and forwards movement through the document. It also does not have to read the entire input file before starting, so it starts faster than most text editors.") (license gpl3+))) ; some files are under GPLv2+ n value='range'>range
AgeCommit message (Expand)Author
2017-06-18gnu: miniupnpc: Update to 2.0.20170509....Marius Bakke
2017-05-12gnu: miniupnpc: Fix CVE-2017-8798....Marius Bakke
2017-04-21gnu: miniupnpc: Use @dfn mark-up....Tobias Geerinckx-Rice
2017-04-21gnu: miniupnpc: Update to 2.0.20170421....Tobias Geerinckx-Rice
2017-01-12gnu: miniupnpc: Update to 2.0.20161216....Tobias Geerinckx-Rice
2016-11-25gnu: miniupnpc: Improve synopsis and description....Tobias Geerinckx-Rice
2016-11-25gnu: miniupnpc: Use the correct ‘upnpc’ in ‘external-ip’....Tobias Geerinckx-Rice
2016-11-25gnu: miniupnpc: Use ‘modify-phases’ syntax....Tobias Geerinckx-Rice
2016-11-25gnu: miniupnpc: Update to 2.0....Tobias Geerinckx-Rice