;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages less) #:use-module (guix licenses) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public less (package (name "less") (version "481") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/less/less-" version ".tar.gz")) (sha256 (base32 "19fxj0h10y5bhr3a1xa7kqvnwl44db3sdypz8jxl1q79yln8z8rz")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (home-page "https://www.gnu.org/software/less/") (synopsis "Paginator for terminals") (description "GNU less is a pager, a program that allows you to view large amounts of text in page-sized chunks. Unlike traditional pagers, it allows both backwards and forwards movement through the document. It also does not have to read the entire input file before starting, so it starts faster than most text editors.") (license gpl3+))) ; some files are under GPLv2+ t type='submit' value='search'/>
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-24 12:20:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-24 17:40:14 +0300
commite97a90943c595205244262803251453ce12ffdd0 (patch)
treed2da19f38f0c399a691292a1e8626d988885ab7a
parent14ae9cbcb420c7578d4bf95f9061a19ad2ca9e9d (diff)
downloadguix-e97a90943c595205244262803251453ce12ffdd0.tar.gz
guix-e97a90943c595205244262803251453ce12ffdd0.zip
gnu: Remove rust-crates-io-0.31.
* gnu/packages/crates-io.scm (rust-crates-io-0.31): Delete variable.