;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages less) #:use-module (guix licenses) #:use-module (gnu packages ncurses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public less (package (name "less") (version "530") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/less/less-" version ".tar.gz")) (sha256 (base32 "1qpj2z38c53qmvqn8jaa0kq26q989cfbfjj4y0s6z17l1amr2gsh")))) (build-system gnu-build-system) (inputs `(("ncurses" ,ncurses))) (home-page "https://www.gnu.org/software/less/") (synopsis "Paginator for terminals") (description "GNU less is a pager, a program that allows you to view large amounts of text in page-sized chunks. Unlike traditional pagers, it allows both backwards and forwards movement through the document. It also does not have to read the entire input file before starting, so it starts faster than most text editors.") (license gpl3+))) ; some files are under GPLv2+ ='range'>range
AgeCommit message (Expand)Author
2016-07-20gnu: openmpi: Make binaries reproducible....Eric Bavier
2016-07-20gnu: openmpi: Update to 1.10.3....Eric Bavier
2016-04-14gnu: hwloc: Update to 1.11.2....Ludovic Courtès
2016-02-03gnu: hwloc: Build without numactl support on armhf....Andreas Enge
2015-11-20gnu: openmpi: Update to 1.10.1....Eric Bavier
2015-11-20gnu: hwloc: Update to 1.11.1....Eric Bavier
2015-08-24gnu: hwloc: Propagate libpciaccess....Ludovic Courtès
2015-06-29gnu: openmpi: Upgrade to 1.8.5....Eric Bavier
2015-06-29gnu: hwloc: Move numactl to inputs....Eric Bavier
2015-06-29gnu: hwloc: Upgrade to 1.10.1....Eric Bavier
2015-06-25gnu: Replace versioned gfortran inputs with just "gfortran"....Ricardo Wurmus
2014-10-20gnu: Add 'version-prefix' and 'version-major+minor'; use them....Ian Denhardt
2014-05-18gnu: openmpi: Add memchecker support....Eric Bavier
2014-05-12gnu: openmpi: Use our hwloc....Eric Bavier
2014-05-09gnu: Add hwloc....Ludovic Courtès
2014-05-08gnu: openmpi: Fix typo in download uri...Eric Bavier
2014-05-08gnu: openmpi: Avoid "open source" verbiage...Eric Bavier
2014-05-08gnu: Add OpenMPI...Eric Bavier